[solved] Script SUPER MIND CONTROL Ⅱ X TURBO isn't working anymore

userscripts
Tags: #<Tag:0x00007ff3b52fd608>

#1

Since some days (possible after server update), userscript SUPER MIND CONTROL Ⅱ X TURBO is not longer working (Windows 10, Firefox 59.0.2 64bit, Tampermonkey, Script version: 2018.4.4).

Console gives me following errors:

Loading “12” shadow release…
userscript.html:71:5
ERROR: Execution of script 'mb. SUPER MIND CONTROL Ⅱ X TURBO' failed! a is null
userscript.html:2:172
<anonym>
moz-extension://d1d5fffc-b992-4fdb-bf05-34a2e7e4815c/userscript.html:2:172
<anonym>
moz-extension://d1d5fffc-b992-4fdb-bf05-34a2e7e4815c/userscript.html:1:68
<anonym>
moz-extension://d1d5fffc-b992-4fdb-bf05-34a2e7e4815c/userscript.html:1:15
<anonym>
moz-extension://d1d5fffc-b992-4fdb-bf05-34a2e7e4815c/userscript.html:1:2
g</< eval:2:479 b eval:1:409 E_u eval:3:135 create/t< eval line 1 > Function:63:96 ka eval line 1 > Function:61:371 create eval line 1 > Function:72:334 e eval line 1 > Function:16:154 runListeners eval line 1 > Function:16:116 anonymous/< eval line 1 > Function:73:405 R eval:10:9
@moz-extension://d1d5fffc-b992-4fdb-bf05-34a2e7e4815c/userscript.html?id=fcae4ffe-1e17-4c05-bcd8-40131809d3e3:234:3
g</<@eval:2:479
@moz-extension://d1d5fffc-b992-4fdb-bf05-34a2e7e4815c/userscript.html?id=fcae4ffe-1e17-4c05-bcd8-40131809d3e3:2:1
@moz-extension://d1d5fffc-b992-4fdb-bf05-34a2e7e4815c/userscript.html?id=fcae4ffe-1e17-4c05-bcd8-40131809d3e3:1:68
@moz-extension://d1d5fffc-b992-4fdb-bf05-34a2e7e4815c/userscript.html?id=fcae4ffe-1e17-4c05-bcd8-40131809d3e3:1:15
@moz-extension://d1d5fffc-b992-4fdb-bf05-34a2e7e4815c/userscript.html?id=fcae4ffe-1e17-4c05-bcd8-40131809d3e3:1:2
g</<@eval:2:479
b@eval:1:409
E_u@eval:3:135
create/t<@eval line 1 > Function:63:96
ka@eval line 1 > Function:61:371
create@eval line 1 > Function:72:334
e@eval line 1 > Function:16:154
runListeners@eval line 1 > Function:16:116
anonymous/<@eval line 1 > Function:73:405
R@eval:10:9
userscript.html:2:272
Loading AcoustIDs…
userscript.html:71:5
Versuch, eine verbotene Kopfzeile zu verwenden, wurde abgelehnt: Content-length eval line 2 > eval:684:2
Versuch, eine verbotene Kopfzeile zu verwenden, wurde abgelehnt: Connection eval line 2 > eval:685:2
TypeError: data.media is undefined[Weitere Informationen] eval line 2 > eval:619:11 

Already removed and reinstalled script. Also tried older version (2018.1.4). No chance.

Any hints to get it back working? Thanks.


#2

Also tried with Chrome (Version 66.0.3359.139 64-Bit. Similar error:

ERROR: Execution of script 'mb. SUPER MIND CONTROL Ⅱ X TURBO' failed! Cannot read property 'getAttribute' of null
(anonymous) @ userscript.html?id=6d73eb69-6041-4c16-be7e-a1d4b188be12:2
userscript.html?id=6d73eb69-6041-4c16-be7e-a1d4b188be12:2 TypeError: Cannot read property 'getAttribute' of null
    at Window.eval (userscript.html?id=6d73eb69-6041-4c16-be7e-a1d4b188be12:234)
    at <anonymous>:2:120
    at eval (userscript.html?id=6d73eb69-6041-4c16-be7e-a1d4b188be12:2)
    at eval (userscript.html?id=6d73eb69-6041-4c16-be7e-a1d4b188be12:3)
    at Object.eval (userscript.html?id=6d73eb69-6041-4c16-be7e-a1d4b188be12:1612)
    at eval (userscript.html?id=6d73eb69-6041-4c16-be7e-a1d4b188be12:1614)
    at eval (<anonymous>)
    at <anonymous>:2:120
    at Object.b [as F_c] (<anonymous>:1:398)
    at Object.E_u (<anonymous>:2:285)
    at p (eval at exec_fn (e0a94646-4475-4226-b3e6-5f7feda050a5?tport=8000:1), <anonymous>:62:438)
    at oa (eval at exec_fn (e0a94646-4475-4226-b3e6-5f7feda050a5?tport=8000:1), <anonymous>:61:194)
    at Object.create (eval at exec_fn (e0a94646-4475-4226-b3e6-5f7feda050a5?tport=8000:1), <anonymous>:72:116)
    at e (eval at exec_fn (e0a94646-4475-4226-b3e6-5f7feda050a5?tport=8000:1), <anonymous>:16:131)
    at Object.runListeners (eval at exec_fn (e0a94646-4475-4226-b3e6-5f7feda050a5?tport=8000:1), <anonymous>:16:90)
    at eval (eval at exec_fn (e0a94646-4475-4226-b3e6-5f7feda050a5?tport=8000:1), <anonymous>:73:201)
    at HTMLDocument.k (<anonymous>:9:9)

#3

I thought that I heard that @jesus2099 was waiting until the main MusicBrainz website was updated (causing the script to fail) before issuing the update. I expect we’ll see something soon.


#4

#5

I’m NOT using the beta version. This happens with the regular version.

I will wait for a future update.

Thanks for the script.


#6

I think he was referring to the beta website (https://beta.musicbrainz.org) and not a beta version of the script. That’s where the problem was first noted.


#7

To clarify: This happens on http://musicbrainz.org.


#8

It does now, because the updates from the beta site were just recently applied to the main site. This is what @jesus2099 was waiting for before issuing an update to his script. It wouldn’t have made sense to update the script such that it worked on the beta web site but failed on the main production site.


#9

Thanks @rdswift! :slight_smile:

I’m now back on a computer and it’s fixed!


#10

Thank-you, sir. You have made me (and many others) very happy with this announcement. I didn’t realize just how much I relied on the scripts until they stopped working. I now have a better feel for the added value they provide. Thanks again.


#11

It’s working again after update. Thanks a lot!!!


#12

When scripts are off, MusicBrainz feels a little bit light and refreshing though.
But soon afterwards, I am missing some features, indeed. :slight_smile: