[Solved] How do I find out the internal "NAMES" of Tag Fields?

So, I have a bunch of $unset scripts, and most of them are obvious, but some aren’t working.
What might be the obvious name, isn’t?

For example, $unset(totaltracks) works fine.
However, I don’t know what the name of “Disk Number” is…?
I’ve tried:
$unset(disk number)

But none of them work… i.e. will not be removed from the Tags I want to edit/display info etc.

The known tags and variables are all documented at Tags & Variables — MusicBrainz Picard v2.7.0b1 documentation . The tag name for the disc number is discnumber.

1 Like

And I’m an idiot… I was spelling it wrong, LOL

Blame the English language :smiley: Both “disc” and “disk” are used, with a preference for “disc” maybe if we talk about CDs and a preference for “disk” if we talk about computer storage thingies.

LOL yep…

However, somethings wrong, it’s STILL not being removed?
Everything is for sure right this time, and I think it was previously, I had just mispelled it testing it today.

Well, $unset will not delete the tag. It will clear the disc number loaded from MusicBrainz. That means unless you have enabled “clear existing tags” your existing value will be kept. Use $delete(discnumber) to actually mark the tag for deletion.

Huh… That’s weird. How come $unset removes a bunch of other tags, they don’t even show in the window, and I was told to use this tag to remove tags I don’t want to have in my files?
Also, if $unset works like that, how come the disc number isn’t removed from the database window side?


You probably have existing disc numbers in the file tags already, and did not have any values for the other tags you unset. You can see that, if you have a value in the “Original Value” column it means the tag is already present in your files. If “New Value” and “Original Value” are the same (and the row is not displayed colored) there will be no change after saving.

If there is neither an existing nor a new value to write for a tag that tag will not show up in the tag view (the tag wasn’t in the file originally and won’t be written either).

Yep, you’re right…

I guess the other tags weren’t written yet, so the $unset worked fine and never showed after I put the scripts in.
Now, due to your great help I know I need to have that $delete script in certain cases like this.

Thanks again, you’ve been great…! :slight_smile:

1 Like