[SOLVED] Filenaming and TAGS when "feat."

Tags: #<Tag:0x00007f05090defc0>


Hi Picarders! :wink:
Hope to be in the right place asking my question…
Maybe it has already been answered, but i dunno how to seek it, 'cause i don’t know how to “name” this demand.
What I need is to change Picard behavior in naming tags and filenames.
But first, let me post you an image.

This is not how I want the tags to be saved. I would like to keep the infos about who is in the “feat”, but I want only the artist of the album (in this case Holly Herndon) to be shown and used for sorting by the music player.

Now let’s consider the “filenaming”. I like the standard schema “NN Songname”.
So… Why if an album has featurings, Picard adds them to the filename?

01 Holly Herndon - Interference.m4a
02 Holly Herndon - Chorus.m4a
03 Holly Herndon feat. Colin Self - Unequal.m4a

I would like this way:
01 Interference.m4a
02 Chorus.m4a
03 Unequal.m4a

Can you please help me setting Picard right to my needs?



Hi muzakzound!

If you want to make the most of your music files, and are interested in comprehensive tags, consider leaving the artist field as is, and sorting your albums by ‘Album Artist’ instead, without having to water down other tag fields.
Most decent players should support this option.

Otherwise you can set everything in Picard > Options > Options > Tags / File Naming
There’s also a couple of helpful plugins that remove the ‘feat’ from tags for you here: https://picard.musicbrainz.org/plugins/


Thanks aerozol! I made it, working with plugin and renaming pattern. :sunglasses: