Shouldn't UTF-8 be default for ID3v2.4?


In Picard’s settings panel you can set to use ID3v2.4
Doing that enables the option to use UTF-8 instead of UTF-16.
But since UTF-8 is the preferred default for ID3v2.4, shouldn’t it also activate UTF-8, instead of making it an option?


Makes sense to me. I don’t know if there’s some historical reason it is how it is though. Regardless, I filed a ticket on your behalf:
Feel free to go make an account on the ticket tracker so you can follow its progress more closely (and maybe vote and comment on it as well).


Thanks, I might do that at a later time.