Scripting Basics

Tags: #<Tag:0x00007f0507eecf10>


I’ve been around for ages, but never really scripted… so thanks for your patience in advance!
On Picard 1.4.2.

The only scripting I’ve used is:
(put a ‘country’ tag onto tracks with the artists country, mainly so I can browse for New Zealand artists and easily separate artists with the same name)

Question 1:

The current scripting interface has a button:
[Add new script]
With a text field below it.

When I put the script into the text field, and hit ‘make it so’, I assume it starts applying the script?
The question is, when I hit [add new script], where do I see my active scripts/old scripts? It just clears the text and title field and I can’t see the others. The documentation link hasn’t helped me.

Question 2:
$set(country,%_artistcountry%) doesn’t seem to work anymore, any quick fixes? :wink:


1, There is a user interface bug in picard that stops the list of scripts from being shown.
The screen is split in to two sections, one containing the list of scripts and the other containing the details on the currently selected script.
The seperator can be moved and is sitting all the way to the left of the screen.
put your cursor on the left of the window and you will see the icon change to arrows allowing you to drag this bit towards the middle.
You should then be able to move it so it looks like the below.

  1. i’m not sure why this is not populated.
    There is a view script variables plugin, using this will allow you to gith click a file and see what variables are set and use this when building scripts.


For the first, drag the left side of the text editor to the right; the list of scripts and the management buttons like to hide themselves or first use. I think I remember hearing that that was fixed for the next version, but the bug happens so frequently that there should probably be a note in the documentation somewhere.

For the second, I’ll check tomorrow unless someone solves it earlier, but at a guess I’ve had scrips fail silently because of syntax errors; I’m not sure if that spills over to other scripts as well so one somewhere buried in that currently-hidden list could be keeping it from working.


%_artistcountry% is not a standard variable in Picard. Did you have a plugin enabled which sets this? Or another script?


Thank you, easy!

Not that I know of or remember :open_mouth: To be fair, it would have been quite a few years ago that I set it up so perhaps…
Can anyone think of one, or another way to make this work again?