Schema sequence mismatch


when trying to populate DB

./admin/ --createdb --import /tmp/dumps/mbdump*.tar.bz2 --echo

I get this:

Schema sequence mismatch - codebase is 22, /tmp/dumps/mbdump-cdstubs.tar.bz2 is 23

Any idea what is going wrong here?

Thanks and regards,


Sorry, just realised nobody answered that email yet. That means that you haven’t updated your code since the last schema change. You can find instructions for the update at our blog - if something goes wrong, let us know :slight_smile:

Since it’s a fresh import, the update instructions are overkill. Just check out a recent version, update your lib/, and do the import.

Thanks, is there an easy way to upgrade to Postgresql 9.5 on the ubuntu VM? Tried but dependencies fail :frowning:

If i remember the old vm was running ubuntu 12.04.
You may be able to add the postgreql repository and download a newer version of postgres from there.

You could also try and upgrade ubuntu from 12.0.4 to 14.0.4 and then 16.0.4 where postgres 9.5 is avalable.
The database will not automaytically upgrade when you change versions so the data exists in the old postgres datbase.
There is the pg_upgrade tool that should allow you to upgrade versions.
The other way is you can export and import the data from one version to the new version by running pg_dump from the old instance to psql connected to the new instancce.

The easiest way is to download the new vm and start again as that has the software installed and a working database.


running an upgrade right now…

but another question, you are talking about “new vm”, I installed this one:

is there a more recent one?

many regards!

Yes, a new one is under development:

forget this. --db-password and setting db to musicbrainz_db instead of musicbrainz in /home/search/bin/reindex did the job. now reindexing. let’s see what tomorrow brings :slight_smile: