Problems with "Add Cluster As Release" picard plugin


#1

It was working fine yesterday, but now no fields on the website are actually populated when I use this plugin. I’ve cleared out all picard configuration and caches and reinstalled, and tried two different browsers (Chrome and Safari). No luck. Picard 1.3.2, plugin version 0.7. Is anyone else having similar problems? It’d be helpful to know whether this is a “just me” problem or not.


#2

Having the same problem just now.


#3

This has been reported by @MajorLurker on the bug tracker: PICARD-963. I’ll copy my comment from the ticket:

This is caused by the redirect from HTTP to HTTPS on the main site. Browsers seem to discard the POST data during that redirect. As a workaround, you can set the MB server port to 443 in Picard’s settings.


#4

I made a PR for the plugin:

When that is merged, the plugin should work fine again. Until then, you can use the workaround with setting the MB server port to 443 as mentioned on the ticket.

Edit: The fix has been merged now. Whenever the update gets pushed to the website (I thought this happened automatically?), 0.7.1 should be available which has this fixed.