Problem "Loading Album Information"


#1

I have tried for several days to load every Marilyn Monroe Album that includes “Happy Birthday Mr. President”. I’m not sure what kind of info to send to substantiate this. Here is some info that may be helpful:
http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/I%20Wanna%20Be%20Loved%20by%20You/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 09:10:08 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/I%20Wanna%20Be%20Loved%20by%20You/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/I%20Wanna%20Be%20Loved%20by%20You/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
D: 09:28:02 Debug mode on
D: 09:28:08 Debug mode off
D: 09:29:25 Debug mode on

Thanks for looking. If this is the wrong place to post, please guide me.

Llama lover


#2

Not quite sure, but you probably use an outdated last.FM plugin . They changed their API some time ago. I am actually not up-to-date about the state of the Picard last.fm plugins, but there was at least one claiming to be compatible with the new API. Or as a quick workaround try disabling the last.fm plugin to get the albums loaded.


#3

Hi, I am using last.fm 0.4 and last.fmplus 1.4. I did disable both with no change to my problem. I have very little problem with Picard loading most albums. It is with this particular track that I mentioned above. If Picard tries to load the info automatically or If I tag an album after looking it up in browser, Picard starts to download the info then stops. I have read some of the old posts to similar problems by others and it appears that there might be something about the Marilyn Monroe albums containing the track “Happy Birthday Mr. President” that is causing the conflict.

I have tried to tag the Marilyn Monroe albums from two different computers at two different locations and have the same result. Sincerely, Llama Lover.


#4

Can you give a link to an album that doesn’t load? If it is indeed related to specific albums maybe the current development version 1.4 of Picard is able to load them. See the downloads of daily builds on http://picard.musicbrainz.org/downloads/

Also note that the MusicBrainz servers are at the moment under heavy load, and sometimes loading albums will fail. You can usually just retry it in those cases (right click -> Refresh). See the discussions at Rate limiter has changed? and State of things, Q2 2016


#5

This is a link to one of the albums that will not completely download. I tried it again this morning with the same results. Yes, I am familiar with refreshing and so far I can’t come up with a solution. I will try to load the current development version. I have noticed that during the download process Picard seems to stop when it is trying to load the cover image. Thanks for your assistance!


#6

I tried this, and I got basically three different behaviors:

  1. The boring case: The album did just load as it should
  2. The album did not load and I saw the “could not load album” error. A look at the log shows the “Service Temporarily Unavailable” error due to high server load. One or several retries helped here
  3. Now the interesting part I only experienced when setting Picard to use “beta.musicbrainz.org”: Picard kept displaying the “loading album” info, nothing happened, no output in error log. Started Picard with “–debug” and got this:
D: 11:58:06 Loading album 429b7313-d6e4-49b6-a7d2-95503c466fc4 ...
D: 11:58:07 Last request to (u'beta.musicbrainz.org', 80) was 1000 ms ago, starting another one
D: 11:58:07 GET http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels
D: 11:58:07 Received reply for http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels: HTTP 301 (Moved Permanently) 
D: 11:58:07 Redirect to https://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels requested
D: 11:58:08 Last request to (u'beta.musicbrainz.org', 80) was 1000 ms ago, starting another one
D: 11:58:08 GET http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels
D: 11:58:08 Received reply for http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels: HTTP 301 (Moved Permanently) 
D: 11:58:08 Redirect to https://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels requested
D: 11:58:09 Last request to (u'beta.musicbrainz.org', 80) was 1000 ms ago, starting another one
D: 11:58:09 GET http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels
D: 11:58:09 Received reply for http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels: HTTP 301 (Moved Permanently) 
D: 11:58:09 Redirect to https://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels requested
D: 11:58:10 Last request to (u'beta.musicbrainz.org', 80) was 1000 ms ago, starting another one
D: 11:58:10 GET http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels
D: 11:58:10 Received reply for http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels: HTTP 301 (Moved Permanently) 
D: 11:58:10 Redirect to https://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels requested
D: 11:58:11 Last request to (u'beta.musicbrainz.org', 80) was 1000 ms ago, starting another one
D: 11:58:11 GET http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels
D: 11:58:11 Received reply for http://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels: HTTP 301 (Moved Permanently) 
D: 11:58:11 Redirect to https://beta.musicbrainz.org/ws/2/release?release-group=4c821f5c-bf04-4fa8-a3be-874b59dd36d8&limit=100&inc=media+labels requested

Basically an endless redirect, that doesn’t happen with other albums. Not yet sure why Picard never gets this right and why it does not happen for other albums. I also could only trigger this on beta. Can you check whether this matches your behavior? Also try starting Picard with the --debug command line parameter and post the log output here.

Update: I tested with both Picard 1.3 and 1.4 dev, same behavior.


#7

Isn’t beta now TLS-only? http redirects to https for me…


#8

Yes, and Picard didn’t handle that very well, but I see it got fixed a few days ago in https://github.com/metabrainz/picard/commit/64b8c0106b5201a652923f43bb534f73f2f024e7. Ok, lesson for now is just don’t use beta with stable Picard. But I currently don’t think this actually is the problem @Llama_lover encountered. Looking forward to get some more information :slight_smile:


#10

Here is some additional info on my set up. Windows 7 home with all service packs and updates.
MBP V 1.3.2. Plugins in use are: Add Cluster as release 0.5, album artist website 0.3, classic disc numbers 0.1, disc numbers, 0.1, last.fm 0.4, last.fm.plus 0.14, release type 1.2.


#11

That’ s in general the correct output, it just lacks the essential part :wink: What you should do is load Picard with the --debug switch, as you did, and then try to load the affected Monroe album. The output should then hoefully tell us something about what is happening when loading this album.

Also please try the following:

  1. Try the 1.4 development version just to test whether this is some issue that has already been fixed.
  2. Disable all plugins , restart Picard and see whether this fixes the loading. If it does you can re-enable the plugins one by one
  3. If it still does not load, tell us what exactly you see when loading the album. Does it get stuck at tty he “loading album” info or does it show the “Error loading album” after a while

#12

W: 16:30:59 Module ‘albumartist_website’ conflict: unregistering previously loaded u’Album Artist Website’ version 0.3 from ‘C:\Program Files (x86)\MusicBrainz Picard\plugins\albumartist_website.py’
W: 16:30:59 Module ‘cuesheet’ conflict: unregistering previously loaded u’Generate Cuesheet’ version 0.1 from 'C:\Program Files (x86)\MusicBrainz Picard\plugins\cuesheet.py
W: 16:30:59 Module ‘release_type’ conflict: unregistering previously loaded ‘Release Type’ version 1.2 from 'C:\Program Files (x86)\MusicBrainz Picard\plugins\release_type.py’
E: 16:31:05 Network request error for https://musicbrainz.org/ws/2/collection: Error downloading https://Llama%20lover:@musicbrainz.org/ws/2/collection - server replied: Service Temporarily Unavailable (QT code 301, HTTP code 503)
E: 16:31:05 Error loading collections: Error downloading https://Llama%20lover:@musicbrainz.org/ws/2/collection - server replied: Service Temporarily Unavailable
E: 16:33:49 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Do%20It%20Again/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Do%20It%20Again/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:49 Network request error for http://ws.audioscrobbler.com/1.0/artist/Marilyn%20Monroe/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/artist/Marilyn%20Monroe/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:49 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Do%20It%20Again/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Do%20It%20Again/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:49 Network request error for http://ws.audioscrobbler.com/1.0/artist/Marilyn%20Monroe/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/artist/Marilyn%20Monroe/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:49 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Kiss/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Kiss/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:50 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Kiss/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Kiss/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:50 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Anyone%20Can%20See%20I%20Love%20You/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Anyone%20Can%20See%20I%20Love%20You/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:50 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Anyone%20Can%20See%20I%20Love%20You/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Anyone%20Can%20See%20I%20Love%20You/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:50 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Every%20Baby%20Needs%20a%20Da%20Da%20Daddy/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Every%20Baby%20Needs%20a%20Da%20Da%20Daddy/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:50 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Every%20Baby%20Needs%20a%20Da%20Da%20Daddy/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Every%20Baby%20Needs%20a%20Da%20Da%20Daddy/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:51 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Ladies%20of%20the%20Chorus/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Ladies%20of%20the%20Chorus/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)
E: 16:33:51 Network request error for http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Ladies%20of%20the%20Chorus/toptags.xml: Error downloading http://ws.audioscrobbler.com/1.0/track/Marilyn%20Monroe/Ladies%20of%20the%20Chorus/toptags.xml - server replied: Not Found (QT code 203, HTTP code 404)

I will try :[quote=“outsidecontext, post:11, topic:47163”]

  1. Try the 1.4 development version just to test whether this is some issue that has already been fixed. I will try this in a few hours.

  2. Disable all plugins , I have done this with no change in my problem.
    [/quote]

  3. I select the Happy Birthday Mr. President track from my file and MB automatically tries to load an album. The download column starts around 12 to 20 then freezes when it gets down to 2. I have gotten the “could not load album” notice once or twice. Refreshing once or twice will start the download but it stops when it gets down to 2. If I click remove, the “album countdown” number continues to stay at 2. I have to close & reopen MB to clear it. Yes, it freezes while displaying “loading album”.

If I “lookup in browser”, and tag an appropriate album, MB starts its’ countdown and stops at 2. I have left MB in the “frozen state” for over an hour and nothing changes. Keep in mind that MB does not freeze up, only the Marilyn Monroe download. I can select a different track from a different artist and MB does its’ thing correctly.

If I choose another appropriate Marilyn Monroe album in the browser and tag it, the second album starts to download until the “album countdown” column reaches the number 3. If I try to load an additional MM album, it will countdown until it reaches 4 etc… Curious huh.


#13

After a week of trying, I finally successfully downloaded one of Marilyn Monroes’ albums. I had no better luck running the Dev version. I appreciate the troubleshooting help outsidecontext offered. Maybe this was just a fluke. Thanks, Llama lover.


#14

Glad to hear you got it working. I can’t come up with a better explanation than to blame the general MB load issues. Hopefully this will get better soon.