Problem Installing MusicBrainz Picard 2.1.2 on macOS Mojave


#1

When I click on “Open” to install the package (see screen capture), the dialogue window closes, after which there is no further response from my computer. Literally, nothing happens.

I am also not seeing any issue in Preferences > Security & Privacy.

Suggestions?

My computer:
2018 Mac mini
Mojave 10.14.3


#2

It looks like you are trying to start Picard directly from the .dmg image. There have been reports that this does not always work. Please copy the Picard app to your Applications folder and try starting it from there.


#3

Thanks, that solved the problem. I was expecting an installation process, but apparently there isn’t one :slight_smile:


#4

Thanks for confirming this behavior. We need to figure out what is happening. Unfortunately there seems to be different behavior in some cases, e.g. I usually can run the builds from the dmg image. I think this issue might be related to what was reported at https://tickets.metabrainz.org/browse/PICARD-1479 , even though that issue specifically claims that it worked when started directly from the .dmg image.