Picard v2 crashes when inputting %album%

picard
Tags: #<Tag:0x00007f24c3cfcf58>

#1

I just installed Picard on Arch Linux. When I enable “Rename files when saving” and enter %album% under “Name files like this” it instantly crashes.


#2

I ran debug and heres the results: Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/picard/ui/options/renaming.py”, line 130, in check_formats
self.update_examples()
File “/usr/lib/python3.6/site-packages/picard/ui/options/renaming.py”, line 163, in update_examples
example2 = self._example_to_filename(self.example_2())
File “/usr/lib/python3.6/site-packages/picard/ui/options/renaming.py”, line 148, in _example_to_filename
filename = file._make_filename(file.filename, file.metadata, settings)
File “/usr/lib/python3.6/site-packages/picard/file.py”, line 373, in _make_filename
return os.path.realpath(os.path.join(new_dirname, new_filename))
File “/usr/lib/python3.6/posixpath.py”, line 386, in realpath
path, ok = _joinrealpath(filename[:0], filename, {})
File “/usr/lib/python3.6/posixpath.py”, line 420, in _joinrealpath
if not islink(newpath):
File “/usr/lib/python3.6/posixpath.py”, line 169, in islink
st = os.lstat(path)
UnicodeEncodeError: ‘ascii’ codec can’t encode character ‘\xc9’ in position 7: ordinal not in range(128)


#3

Can you try renaming the file or folder first, there is an E with an accent.
Picard should be able to deal with unicode so i’m not sure why it is having a problem with your files.


#4

Thats the thing, this is before I’ve even added any files. I just type %album% into the rename section and it crashes the program, I don’t even get a chance to hit save.


#5

I tried to reproduce this with Picard 2 rc 3, but couldn’t reproduce it. But I could not test on Mac, only Linux.

\xc9 is actually the letter É, which is used in one of the examples. But actually it is supposed to be all unicode and work.

@samj1912, @Zas Any ideas?