Picard Ubuntu packages updated

picard
linux
ubuntu
Tags: #<Tag:0x00007f07647d74f0> #<Tag:0x00007f07647d73b0> #<Tag:0x00007f07647d7270>

#1

Finally updated Picard packages for Ubuntu are available over the official MusicBrainz Ubuntu PPAs. For most users it is recommended to use the stable PPA to install the latest stable release of Picard (1.4.2 at the time of writing this):

sudo add-apt-repository ppa:musicbrainz-developers/stable
sudo apt update
sudo apt install picard

Up-to-date stable packages are available for Ubuntu 14.04 Trusty, 15.05 Vivid, 16.04 Xenial, 17.04 Zesty and upcoming 17.10 Artful.

For users wanting to try out the latest development release there is also a daily build PPA available. Please note that the current Picard 2.0 development releases are a major update to the codebase and everything is still work in progress, so it might be more unstable then usually. Also due to updated dependencies the Picard 2 daily builds are only available for Ubuntu 17.04 and 17.10.

Why did this take so long?
TL;DR: Lack of time and people

Longer version: Having the Ubuntu packages updated was requested by a lot of people. In the past we had managed to update the PPAs at around release time, but this time Picard 1.4 was released in February and the stable PPA was outdated since then. The daily PPA was broken even longer. One reason is that we use the build service on launchpad.net to build the packages, and since Picard on launchpad.net was migrated over to Git the existing builds were broken, and getting it right again took a bit longer. Combine this with the fact that I was the primary updater of those scripts but don’t use Ubuntu anymore (as most of the Picard dev team AFAIK) and that I also struggle to get a couple of hours from time to time to do some FOSS work it got delayed longer than I had hoped.

The good news is that the builds are now up-to-date again and maintaining them should be easy now. But as usual help is always welcome, not only for packaging but for Picard development in general.


Linking to browser in Picard not working << SOLVED
PPA dists update request
Can log into website, but not via Picard
Can't add files from a mounted partition
#2

I think this might be a nice thing to post about on the blog as well. Would you be interested in writing up a version of this for posting there? (Or maybe just copy this verbatim? :stuck_out_tongue: )


#3

It’s already up on the blog :stuck_out_tongue_winking_eye: Posted it shortly after the update here.


#4

With todays Picard 2.0 release the stable PPA has also been updated.

As mentioned above due to the upgrade to PyQt 5.7 only newer Ubuntu versions are supported. Currently these are Ubuntu 17.10 (Artful), 18.04 (Cosmic) and the upcoming 18.10 (Bionic).