Picard doesn’t create subfolders for albums


#1

Here is problem. I tryed to look at script, tryed to press “Default” but no results.


#2

Do you have “move files” enabled?


#3

Yes, looks like problem in script. In examples showing “Help!”


#4

I am unclear what you are doing. The file naming with only take place after you save them. Are you doing this? ANd does it say they saved correctly?


#5

Yes it say “saved”. Well… I tried to re-organize my music library. I press “Cluster” and Picard creates folders for Artists everything is okay in this stage. After Picard finish process. I enter just created by Picard Artist folder, and here no subfolders for each album. All songs just layed in Artist folder.


#6

Hi @DAAaa :slight_smile:
I don’t think this is a bug, otherwise a lot of other people would be having the same problem (although I guess it could still be!)

Picard unfortunately is kind of tricky, so I’m going to start at the start to make sure we haven’t missed any steps.

1: Add files to Picard by dragging them in, or clicking on ‘add folder/ add files’. They will appear on the left hand side of Picard.
2: Hit ‘cluster’. This will group your files together within Picard using the existing ‘album’ tags. Cluster does not change your files or create folders in any way, just groups them in Picard.
2.5: If all you want to do is move files, and not update any information, now you can select a cluster, or just a file/track, and hit ‘save’ to apply your settings based on existing tags.
3. Picard’s made to update your tags though, so selecting a cluster and hitting ‘Lookup’ will look for a matching item in our database using the tags, or if you don’t have any tags/ the tags are wrong you can use ‘Scan’ which will ‘listen’ to the track to try and match it.
4. Double check that it’s moved the files on the left to the right items in the database on the right, and if you’re happy with it, hit ‘save’ to apply the new information from MB to the files, and also create the folder structure based on your settings.

Does that help?

Just a note, Picard works best with just a few albums at once, and please try it on a backup of your files first, it will overwrite existing information.


#7

You should also show us your file naming script, so we can check whether there is a problem with the script.


#8

Thanks i did it before. Still the same


#9

I show it in screenshot. https://farm1.staticflickr.com/318/32312615945_c86a885405_b.jpg
Yes looks like a problem with script, look at “examples” M:\The Beatles\Help!\07… “Help” looks like error in script. I think it was me, but i pressed ‘default’ but script didnt changes.
$if2(%albumartist%,%artist%)/$if($ne(%albumartist%,),%album%/)$if($gt(%totaldiscs%,1),%discnumber%-,)$if($ne(%albumartist%,),$num(%tracknumber%,2) ,)$if(%_multiartist%,%artist% - ,)%title%


#10

I am still not entirely sure what you are doing, but if it does not create subfolders for the script you are using (its the default) it means the %albumartist% is not set (due to $if($ne(%albumartist%,),%album%/)).

I have a suspicion: You said above you are using “Cluster” and then “Save” the files? That would mean you do not actually match the files against MusicBrainz and do not change the tags at all. This will just use the tags already inside your files, and if those do not have the albumartist tag set the script will not create a sub folder. You have to use “Lookup” on the cluster to actually load the data from MusicBrainz in the right pane.

I suggest you take a look at the documentation, especially How to Tag Files and Basics.

You can also change the script by replacing $if($ne(%albumartist%,),%album%/) with just %album%/, but for all the data loaded from MusicBrainz this should actually not make a difference except for standalone recordings.