Original Year Last.fm.plus not working?


#1

Hello all, first time poster so please be gentle

I have very large mp3 collection which i have previously tagged to a very high standard using a combination of tag&rename and several scripts within mediamonkey such as genre finder (from last.fm) and earliest date finder which scrapes original release dates from musicbrainz. Using earliest date finder I overwrote the “date” fields of my mp3’s rather than use the carte blanche album release date. I find this works nicely with my various media players. Lately mediamonkey has been screwing around with my music so ive been toying with other software for a new tagger program. Picard is nice because i have also recently started using KODI so the musicbrainz tag info that picard provides works well with it.

So my mp3s are already in very good condition tag-wise but i thought i would run them through picard just to tidy up any errors that have crept in. I installed the last.fm.plus plugin and wasnt too fussed if the “date” fields of my collection got overwritten as original release date is tagged in another field (id3:TORY if i recall the documentation)

Now ive tried it with a few test albums and unfortunately ORIGINAL RELEASE DATE and ORIGINAL YEAR are just being set to the album release date. For example Phil Colins …Hits album was released in 1998 and all tracks show this as original release date/year.

So heres my questions:

  1. Is the original year feature of the last.fm.plus plugin working?
  2. If not, can i add a script line to tell picard not to pull the date from musicbrainz thus preserving the dates i got from earliest date finder?

Look forward to your responses, thanks


#2
  1. I’m not sure that plugin is working at all

  2. You don’t even need a script. There is s field on options, I believe under “tags”, where you can enter tag names (case sensitive) that you don’t want Picard to overwrite


#3

Thanks for the quick response, i’ll deactivate the last.fm.plus plugin from now on since its not working. You are right there is an option in the UI to preerve tags which i’ve just tried and found it to be working for “date” (i.e. picard no longer overwrites my dates) but not for “originaldate” or “originalyear”.

I have this syntax entered in the preserve tag field: date,originaldate,originalyear

Any chance you could do a quick dummy run to see if you can get originaldate and originalyear to be excluded?

Maybe i’ve cocked the syntax up in the preserve tag box


#4

Hmm. I have “originaldate” and “origyear” in my preserve tags list. The only thing I can think of would be if your tag name doesn’t exactly match what Picard uses.

But beware that the field description is very literal: it will prevent existing tags from being overwritten or deleted, but it will still write the tag if it is currently empty.


#5

Thats the issue, my orginaldate and year tags are currently empty so Picard is tagging them. Yes you are right the description of preserve tags is very literal! Would probably be better if the function of this option also excluded blank fields

Thanks for your help