Opus acoustIDs from Picard


It appears I am unable to submit acoustIDs via Picard for Opus files. Does this sound correct? I am able to submit from MP3 and MP4 (AAC encoded in M4A container) without problems.


Generating fingerprints for opus files works for me. Can you look at Picard’s log to see if there is any error message when fingerprinting the Opus files?

Also what operating system are you using?


I would need to get back to you on the log file when I have a moment to do that, but I am using Ubuntu 17.04. But you have answered my question for the most part. The functionality for fingerprint generation for Opus files IS there. So if it is not working for me, that is an indicator of a problem vs a capable functionality issue.

I would consider this resolved at this time. I can always post again if I cannot resolve the issue, now that I know that it should work with Opus.


This is what appears in the error log:

I: 07:53:48 Plugin directory ‘/usr/lib/picard/contrib/plugins’ doesn’t exist
E: 07:53:48 Plugin ‘bpm’ : Traceback (most recent call last):
File “/usr/lib/picard/picard/plugin.py”, line 301, in load_plugin
plugin_module = importer.load_module(_PLUGIN_MODULE_PREFIX + name)
File “/home/brian/.config/MusicBrainz/Picard/plugins/bpm.zip/bpm/init.py”, line 30, in
ImportError: No module named aubio

E: 07:54:18 Fingerprint calculator failed exit code = 1, exit status = 0, error = Unknown error


I have another file and have tried this again. I am getting the same error, and I have also removed the BPM plugin as its code contains a typo that that error is no longer in the log.

The error is: Fingerprint calculator failed exit code = 1, exit status = 0, error = Unknown error

I looked into this a bit further and installed the Acoustid Fingerprinter application. While trying to use this to fingerprint the audio file, it tells me that no audio files are in the selected directory. After reviewing some documentation, I was sure to verify that the audio file was in fact tagged, since I saw a note that only tagged audio files are submitted.

I am using Ubuntu 17.10 and have verified that my chromaprint is 1.4.2-1, which according to the web site, 1.4.2 is the most current version. I have also verified that both the separate acoustid fingerprinter and picard can fingerprint other audio files just fine. I have verified the specific audio file here can play from begin to end without issues, and tried multiple players.

Since the issue is on all Opus files I have tried, I question that maybe there is a sensitivity to something like the encoder used, the encoder settings, specific metadata tags or combination thereof, etc. I know that AAC/M4A does have this issue where there is (mostly in the past) a sensitivity of iTunes and non-iTunes encoded files. There is also the issue as with MP3 files where there are multiple versions/formats a tag can have, and some programs may not be able to read all tag formats. I am only aware of the Vorbis formatting option for Opus though.


Any thoughts on this? I believe I have provided all the info you requested. As I am using more and more OPUS files, it is clear that OPUS is failing each and every time. As this is not specific to Picard, do I need to post this elsewhere? Who is responsible for the scripts behind this?


I have also verified that both the separate acoustid fingerprinter and picard can fingerprint other audio files

Some things I would check:

  • Run fpcalc on some Opus files via the command line and see if the output is the same.
  • Also on the command line, run file opus_track.opus. Post the output if it’s something other than “Ogg data, Opus audio”.
  • If the affected files have the extension .ogg, try again after renaming them to .opus

I was sure to verify that the audio file was in fact tagged, since I saw a note that only tagged audio files are submitted.

Don’t worry: Files must be tagged in order to submit an AcoustID, but they don’t need to be tagged to be scanned by fpcalc/chromaprint.


Thanks for the reply. I have done as you asked and following is the output from one of the test files. Please note that this file (and the others I have) plays perfectly fine. I can also view a spectrogram in Spec, etc. In fact, I used ffmpeg to convert them in order to submit into MB, so that in itself shows the files are of appropriate integrity as they can be converted and result in a good working MP3 file.

What may be an issue is some sort of meta issue or similar, as I have seem happen with iTunes and M4A files in some specific cases.

mm061:~/Music$ fpcalc 1.opus
ERROR: couldn’t find any audio stream in the file
ERROR: unable to calculate fingerprint for file 1.opus, skipping
mm061:~/Music$ file 1.opus
1.opus: Ogg data, Opus audio,

mm061:~/Music$ fpcalc -v
fpcalc version 1.3.1

mm061:~/Music$ mediainfo 1.opus
Complete name : 1.opus
Format : Ogg
File size : 2.99 MiB
Duration : 3 min 14 s
Overall bit rate : 129 kb/s
Album : xxxxxxx
Album/Performer : xxxxxxx
Part : 1/1
Track name : xxxxxxx
Track name/Position : 1/1
Performer : xxxxxxx
Genre : xxxxxxx
Recorded date : xxxx-xx-xx
Writing application : Lavf57.71.100

ID : 1130906698 (0x4368444A)
Format : Opus
Duration : 3 min 14 s
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 kHz
Compression mode : Lossy
Writing library : Lavf57.71.100
Language : English


Since posting the info above, I believe I have found the issue. fpcalc is showing as version 1.3.1, but that is not correct as it should be 1.4.2. Something is funky there as it is up-to-date in package manager. Let me look into this…


Okay, once you sort out the path issue, then just make sure the path in Picard is correct (Options -> Fingerprinting -> AcoustID Settings).

This command might help: match -a fpcalc


It appears I need to apologize. After some research into this, it appears that in MB, the path to fpcalc was different than the system path, pointing to an older version. From this, I am assuming I may have used the download option in Picard and placed the program in the “non system” location, which happens to be my local bin directory. Since most of my stuff is overrides, my local bin directory is first in my PATH, which made it interfere in some other places too. All the while, I did in fact have the recent version installed properly, making it not so easy to notice it being outdated.

I explained in a bit of detail should someone else have issues like this, be sure to check the fpcalc version listed in Picard and make sure it matches the version installed to your system, in my case that is through package manager.

Thanks for the additional checking, and sorry again as this was all user error.


No apology necessary. Thank YOU for identifying the problem (and solution), and possibly saving others from going through the same anguish with it not working properly and not knowing why.