Not numbering tracks

Hi I’ve been using Picard for a while without issue but recently I realized that its not adding track numbers when tagging. Is there a way to enable this and why has it just started doing this (or not doing this)

You’ll need to give us a little bit more details. Are you saying the track numbers are not being added into the tags? Or are you talking about the filenames?

Not sure how Picard would stop doing this, so lets dig into the differences on your system.

Load an album up in Picard. Now lets check the options…

Bring up the OPTIONS from the menu. Go look into TAGS. What is listed in the box “Preserve these tags from being cleared of overwritten”? Making sure the Track number hasn’t accidentally been added in here.

Also in OPTIONS - what Plugins have you got enabled?