No acoustID generated for a single file?

I have a weird situation where one particular file (it’s this recording, and there’s nothing wrong with it) simply will not produce an acoustID, no matter what I’ve tried. All other files from the same release (100 of them) generate/match just fine.

I am using 2.7.3 “portable” in Windows 10, and (in case it matters) it is running off a secondary HDD.

When I scan it, it flashes grey for a second then matches nothing. Dragging it on to the correct track produces the expected “red fingerprint”, and I can click submit, but there is no acoustID tag there, whether I save or not. Have tried this multiple times. Nothing in the log.

I tried starting in debug with the -d flag but I can’t drag/drop any file in that way?

I would open a bug report but I have no idea how to describe it better, was hoping some more experienced user/dev might have some better troubleshooting steps for me. Thanks!

As I understand it, Picard is only submitting the information to the acoustid server, and when the fingerprint grays out that just means that the server accepted what Picard sent. If there’s an internal error in the acoustid server - or even just a delay in applying the fingerprint - there’s nothing useful that Picard logs could tell you.

Thanks, I realize the submission might be a black box. I’m really trying to understand why the acoustID is not tagging the file.

Picard can only set the AcoustID tag if the AcoustID server returns a response that contains the ID, if the fingerprint is freshly submitted or not processed yet there also is no ID yet.

Best would be to enable debug mode (via command line parameter or on the Help > View Error/Debug Log dialog), then scan this file. The log should show the response by the AcoustID server.

This indicates you are running the command prompt as administrator, and in extension Picard itself runs as administrator. Don’t do that, run it with normal user rights. Windows prevents drag and drop between privileged and unprivileged apps.

1 Like

OK thanks @elomatreb @outsidecontext that helped. The acoustID is not a match (which has happened to me on scans many times), and when I move it manually BEFORE hitting a submit button this is what the log says:

D: 08:40:46,590 file.move:615: Moving <FLACFile ‘1.11 - The Chords - Sh-Boom.flac’> from <Cluster ‘Unclustered Files’> to <Track 542b6a49-8326-46eb-897c-7a542aeba048 ‘Sh-Boom’>
D: 08:40:47,701 acousticbrainz_init_.get:72: ABExtractor: AcousticBrainz disabled

Why wouldn’t it let me make a “new” submission?

PS I did not know this!

Windows prevents drag and drop between privileged and unprivileged apps.

Would be great, if you could show the log output of an actual “Scan”. It might actually still be that the AcoustID server did find results, but the AcoustID provided metadata was so different from the existing data on your file that Picard considered it not a valid match. In that case it might help if you lower the threshold in Options > Advanced > Matching for “Minimal similarity for matching files to tracks”.

Did you do a scan before? Only if you do a scan or alternatively “Generate AcoustID fingerprints” on the file Picard will run the fpcalc utility to generate the AcoustID fingerprint, and only then there is something to submit.

1 Like

Sorry, followed along/read through and didn’t think there was anything interesting in it. Can’t put the whole log here because no text-file attaching and it’s too long for inline, but I have it saved.

For posterity, the steps I took:

  1. started Picard (portable 2.7.3), cleared log (in debug mode)
  2. dragged/dropped file in question, it matched by tags (tagged in foobar2000 w/ MB plugin)
  3. dragged it back to unclustered to scan it (side note: I don’t know how to keep it from tag matching first, i want an acoustID on every track)
  4. scanned it, flash grey then white for no match
  5. right-clicked and generated fingerprint
  6. dragged it back to its match, noted a) that there was no acoustID tag and b) that the file appeared as saved (perhaps because I’ve done this umpteen times)
  7. clicked submit, saw success message in debug window, saved log

Needless to say, no acoustID on the file at this point. (I have since the OP scanned and generated for other unmatched files, without incident)

As I wrote above the debug output of this scan step could be useful, as it shows the request made to AcoustID and the response. Otherwise it is all really guesswork. As you had submitted the fingerprint before it would be expected that AcoustID by now has a match for this fingerprint. But it could also be that for some reason the AcoustID server has issues with importing this fingerprint or something.


Sorry, this sat for a long time… a couple more pieces of information, and then I will try to post bits of the log in pieces.

  1. I tried re-ripping this disc, and got the exact same results from the new rip (which I will use for logging, since it’s theoretically “cleaner”)
  2. I found another track on another disc from this release that has a variation of the same problem: this time, the acoustID is “matched” it points to a different release, and when moved produces the usual red fingerprint. The submission again logs as successful, but the acoustID doesn’t appear there; the fingerprint is present on the recording picard found, and it is of course the same track/recording–a different ID appears on both.

OK here are the steps with as much of the log as I can post.

  1. First, try to tag .wav files using the MB plugin in foobar2000 v1.6.9, the full disc ToC does not match so perhaps my drive is doing something wrong (though Exact Audio Copy states in its log “Accurately ripped (confidence 55) [00750984] (AR v2)”) – could use release ID, but never mind, Picard can do it!
  2. Next, drag the .wav files into picard, scan them. They all match first to different releases except the track in question, but no big deal, happens a lot with anthologies. Drag them all into their correct places on my release, interestingly mostly showing as known IDs except for three tracks, all of which are “false” new submissions, i.e. the fingerprints are already associated with the respective MB recordings: here, here, and here. Not posting the log for this, doesn’t seem relevant, though it is odd.
  3. Clear the Picard log, start a new forum reply :slight_smile:
  1. Right-click the unmatched file, choose “generate AcoustID fingerprints”. This is all the log has to say about that:

D: 12:27:15,736 config.event:254: Config file update requested on thread 13576
D: 12:27:23,448 acoustid_init_._run_next_task:252: Starting fingerprint calculator ‘C:\Users\\AppData\Local\Temp\_MEI47682\fpcalc.exe’ ‘E:\m\rippin\doo wop rerip.flacf\11 - Sh‐Boom.wav’

  1. Drag the unmatched file onto the target recording. Note the lack of acoustID in the “new” tags, but also the red fingerprint in picard? Log:

D: 12:29:48,640 config.event:254: Config file update requested on thread 13576
D: 12:29:51,472 ui\itemviews.dropMimeData:778: Drop target = <Track 542b6a49-8326-46eb-897c-7a542aeba048 ‘Sh-Boom’>
D: 12:29:51,472 ui\itemviews.drop_urls:744: Dropped the URL: ‘file:///E:/m/rippin/doo wop rerip.flacf/11 - Sh‐Boom.wav’
D: 12:29:51,473 file.move:615: Moving <WAVFile ‘11 - Sh‐Boom.wav’> from <Cluster ‘Unclustered Files’> to <Track 542b6a49-8326-46eb-897c-7a542aeba048 ‘Sh-Boom’>

  1. With track in question highlighted, click “Submit AcoustIDs” in picard menu. (Turns out this tries to submit the 3 false positives as well, generating an enormous log full of fingerprints in who knows what order, so I redo all this but remove all the other matches this time, and repeat the steps above, with the same log results.) Log:

D: 12:40:34,671 acoustid\manager.submit:113: AcoustID: submitting total of 1 fingerprints…
D: 12:40:34,671 acoustid\manager.batch_submit:159: AcoustID: submitting batch of 1 fingerprints (0 remaining)…
D: 12:40:34,672 webservice_init
.post:591: POST-DATA ‘user=QnROHjO9EX&fingerprint.0=AQADtGKjJ4qC2ceVNTZ45F50-IT8SkLPEVaYHW3UIw9OG03voR9upkINpzrq7QOZVMMr4olenApyC9fTCGXoohEeB9fxFN6hp8oRWlfQGMcrw5t9fPhx9niPkPqRLLePf7jwKsUXvVinHH2OZlKHR-oR84GW3AiP78N1XEuUHGVy5vDxUKiOOZwYkLmEJPpjOEyKMG2O_IRGmkHzHHnSHM9ynJlzhDmS6MEp3mCoVLCSBycu6ZgqRce1ycEf-FmOXJmObxaeHabCHN9xZ2iU-6hx8ch1PNuxUya-OGDXbfiP8Lyg5Ud-BpeN50Gf40rQBw-SXwmypIqSc3ikw0vgkUS_CH-C64KbH09W4Xsm_McsRNIUI1l-nM3xEL-KP0PzBbxy9DnKQ8uS4z8a90F9BW-S4NKDNznSCXqWS3iK5ofmjcebQ1WRKpna4EluvHhD42IodD4c2wvME8yNPMmhKEUo8_jTFKd0XFJ0_Hhy3M_QjMczeDMe9WiiJ8NlIaL0QteJkIKTmsrgdblh_ii1HJ-OhmuToeyRhEfe6Bh_o97EBGeWBz0OJm8Rakn0HEqjDqqZHHlw88IV_ES-o1EedOJ4qBLyPNjhM3iu4Bt6Hc0X6XgunPECLsknxPSR5D6aL0ctH-h7PChvJPlyETHVY1dsYVMYCj-e5Al6XVGwPciDhEuOw7-Ca8GdG_1bnPuRHGHUCJWlNESebBYUL9lj8OpxBtrNoznyD1_E4FkmUcirCFqeB2G7Ez_2JA9qnfCTo5IvPKM3hHmUfIPmDPlxo9KNjU-D8CtOqcN_NIIiOTuhv8Mr5FGGJ9eExw18yfjxSPFRUeGGhk8wP0cPXlKQNomeItmN__iFO4-CR8Wpoxl5VF-QJ9ETJKeOJqfRp4pxOzjD9Dg85IGq6XgeorlSoQ8NHu5uXMeTo_qTGGlN9MaVJMT1BM8lTEySB00kHH_xDD2OLcyJX_ifwqjFRcXn4snwGmGQfAy-ollWKriOX0JPNNJa4vrBOMl8lIlwWhlY5gFKlkazSLvxY3x2TB_8o5eChydyHlqWL5BCXniEs8XaKEcTH9rzoD-2qiTqSId-grkSpBGqbES-QvcRySoa1sO85vg0XMcP14nx5QquZOaRJSeRzMbD4MKVSHnQoNceI4d-5MV5nEWHZPmP_8gTWymaH31wonlYlDx-SmAyCXXA_riCHP0DPbnA6ImCR5Pk4DkxZYfm47lx4_zwGT4bXBGPUxLR5CFKJonx49iHD0wehJIfBSdD_B9-TNmNR6iG_sh3oueOE_0CfUKO0sP14c1R_TF-bFXwREMeHVouHjkXHv_BpFty9F-QS6EEPZEG5gzSX0P_o8aTCKFEGnqyBl-EB38O3znkTE_wN3iySBF-aPlRPkTeJfh1PEMz0sKtCA0uHs0bB12O03jQVER15ISu42UwfTn040eT5whOwpo6PDt6Hn8x6shx4RfEsSTCacTv4GImIcVZaGSWCJky5fjhHjz-I–h6ngeeOgHvWiOkD2ORjoRqgn6B-KWHH-R9oU_oVaOMkOzhcaD8IWWPEfeg5niLQOnF550Bd_hX-jxIHxmDeJ_tMuDj4d2FmHSZDlOdF6ON3i3IDy-ERrr4zTyaIKvozYeTjgZB9WNtLiHRNSHq8fDCrxRMpEIOjoeMB0t-NkRUnp06Axx9ciP_miulDgXY5LzBI14Ccdv1AonI1l-Isce4cyTDJeO1rgeJsKTI_eOhHku9M7wH2WPZon44MMzfMeFo7KOMMczHT2hhVHmYRQb4ce-nXiOpsqInjnyCz_aK0cp5cLX5EOlZFvRJE90fA6J5sqFXg92Bcm4C2GWPDj6fPC1ow9O5chlyDzCXFeCW2mC8MFZ_MePJ0eYJ8IJP9HxPEEaHorYH3me4hQ1zGGO5x_6JEPzCcdNCslmGmFWhsSVXTgTh3iQlM8QZ6R29EsmNGOi49FxLPkZxEiUXcRJYw9xqTcePmjOFX2M68j3Q1WKRzketQpKPgnsoIfqWMjbBm-OZkWvDe0eNLbxB7lidtD4Iz_640m6CBeJP0fzF9WW-HhI42aQ7Ed6BbV-XEk19CjD4zp-obG2TAivMbiM18hrHN_QfAgPnUcuObiuHNcxHs32YaZkoV-QI4ns6Gim7fhRPWCSOCJOG6eOwz1-4hv-BF52ZFWS4MhjPDd8HfuKVw_eJMfDC08uhDohnkd44zj6JMqxtQ-aZylyaH6LMFZYXEevo0m-4w-ak0VaMUW5H3pinIH44zmNvTqO_8LzeMhzIraJQzvccSR6G_kT7AuaSqgjTggfrUfCHFeOHg8TJcxQLULTJNiFsOfQ7MhfNMxmoSRDvGi-ozoaOTyqD59mPPmJ_NDQ3MhDXDquEc074p0EyzEuUcVp5IoywiMTE12_4E6O3PiSB2UiEunR99Dz4EhbXJeEK9KoYcoY1uhxvGnBeBfCnMRzQSN1hOk0F2-k4mKOLkUTXsWnyAHfB71wZkfJ4-mTIvk4I–xTlJwJUlQHg0-Bj_QS17Q7A4RR2cEVZSOXGhG9uhR70cT87h_fD06hnGCZKkyC3l49Fbh6knwJMIT5XCSjEfCvUT6oN6IBz9-VOKZolGyDEnPIhfx_DiuS2h34T-ceMf0JSou5IW-JESYS0LY_fjx6ugeIidFELeNp8ctBiGZH4ozichxNDpqJVyCX8d3RLwXlPqhhRHeEnkm_GhyH1mYVUPJTEzQaC_kIgszBt76oAdzBVZRPcjH4ysFPSqD3vCP4sd_vMkOq52JL55Q6XCFH97Eo96ho4evAIMAAAQIIxBwggOBCFJAAoGQgQIAQ4xwzAnAADAACKMREYIpIpTRAkIBlACUEUcQUsYJY4wgQgkAAApAEAYBMIAwIIwCBADjEJHCGQGUEIQIAIRiyDImgELECSQEYcxAARARhDCBFCFEWO2cAQIIJAABhAQDlGMEAESQMBIJAgVASisElGVGCcaEAEApQpQFSAgCIAYCCAYIV4AZIgxyABEkJBDOEGYIQAgxwgggAgDHgBAASSIARQIYAAgTAhAmgBUIAAiAIE4QAYkhABjhhDAGGCKIUkQCBhADBgmkAJCMGAkQIEAYYAAhQCEBHGWMEIQU0IIBARADDCgGAFUIMCWAIYQhBAlSAkAgmAGOGESQEggZgYQjQggjiBDICAIIgghIYgBgigMggIiKEuSIEAQIQQwAABkmECQIGGAAQ0IhRQl0ghBgGPUAWSAAQlAJx5gABEiHRGICGMAMUoogIogQDCCDhABCAYIYQwQZIghSiAlCmBHEQOSAYw4pYqQQylhAAGNCGEOYAQEQgYQhAhAAAFDUMEYNA1QgxYACCAQDBCPAAWA4FQAgQ4QQnBEGgGBIEEIEYcBIxygAQABjhMOAEEM0MAB6RghRgDABiAHEAYQEZAwg0bAwmDkhFBaESUKQIAQQ4QAQRjDHBEBGAaGAAAQYIhzgTBgGBAEMECCAUQIYpAAwjBEgGDGIAImUEEwAywFAhilDEACYIAiAAYYKoyARBBAigCEECUcgcRIIqhSIAlGiAAECWEcgARAYpgzrDmgJBJIMAIOQAEIgorgCAoEACJAAGaOAAwYABRgRDAiigBBCCEABVEYKIa2wwggjEAcGAUoIABIhhRQAzjBAgDREkAEQAkEIiYAEhCGAlCEEIGAEEQ4oABEEQAiIhCACEAEEkEQZxIwQViHLlECGCaKIQQAQSBA2QAhlAZFCKIAI4ZIwQZQxABCEhABGCGAIQogJ6gwSAghEDDGEEQM&duration.0=147&mbid.0=542b6a49-8326-46eb-897c-7a542aeba048&client=v8pQ6oyB&clientversion=2.7.3.final0&format=json’
D: 12:40:34,682 webservice\ratecontrol.get_delay_to_next_request:118: (‘’, 443): Last request was 83965 ms ago, starting another one
D: 12:40:34,683 webservice\ratecontrol.increment_requests:138: (‘’, 443): Incrementing requests to: 1
D: 12:40:35,129 webservice\ratecontrol.decrement_requests:146: (‘’, 443): Decrementing requests to: 0
D: 12:40:35,130 webservice_init_.handle_reply:540: Received reply for HTTP 200 (OK)
D: 12:40:35,131 webservice_init
._handle_reply:553: Response received: {‘status’: ‘ok’, ‘submissions’: [{‘id’: 626731807, ‘index’: ‘0’, ‘status’: ‘pending’}]}
D: 12:40:35,131 acoustid\manager._batch_submit_finished:197: AcoustID: 1 fingerprints successfully submitted
D: 12:40:35,132 file.update:707: Updating file <WAVFile ‘11 - Sh‐Boom.wav’>
D: 12:40:35,133 acoustid\manager._batch_submit:140: AcoustID submission finished successfully
D: 12:40:35,134 webservice\ratecontrol._out_of_backoff:222: (‘’, 443): oobackoff; delay: 333ms → 333ms; slow start; window size 26.000 → 27.000

No indication of failure, but no acoustID on the file, and starting over the file still scans to match nothing. Is that enough information?

Doing a lookup on the fingerprint submitted in the logs gives no results, and checking the submission status currently shows the submission is still pending. That might indicate some issue on the AcoustID side with importing this fingerprint. @lukz might be able to help

1 Like

Will it only save to the file if the server accepts it as valid?

As long as the server has not accepted the fingerprint submission and assigned it an AcoustID there is no AcoustID to save :wink:

1 Like

I see, I assumed it was “generated” locally, but that makes sense. I fingerprinted a batch of rips today, ~13 releases, and it happened twice more, again with random individual tracks where the release otherwise matched fully (and this from releases in lots of collections). Would be nice to know what’s going on.

The fingerprint, or rather its text representation, is the longish gibberish in your log snippet. You can save it to the tags if you want (there is an option for that in Options > Fingerprinting), but for most that is not very useful. The fingerprint is directly calculated from the audio.

The AcoustID system and how Picard uses it is described at Understanding Acoustic Fingerprinting and AcoustIDs — MusicBrainz Picard v2.7.3 documentation


Sorry, I was unclear–“generated” was the wrong word. I have read the link and understand the process, basically just another version of a checksum.

There is some kind of bug here; either picard is reporting the wrong status or “success” doesn’t mean what it used to. What is odd is that a) after you “generate” the ID quite literally nothing happens–I can’t see that fingerprint, even in the log, unless I submit and b) the log indicates a full submission success (I guess because async/no await?) despite failure.

I’d still like to know what/where the bug is.

The fingerprint is not yet imported into AcoustID, the submission is still pending. See my links above, which currently shows this:

That indicates some issue on the AcoustID server side.

When fingerprints get submitted to the AcoustID server they end up in a submission queue, and the server will process them eventually. Usually this happens very fast, so import should happen in a few seconds or maybe a few minutes. There might be time of high load where it takes longer. But in this case it is quite clearly stuck and not just delayed.

UPDATE: I added a comment about this specific case to Submission stuck in pending state · Issue #70 · acoustid/acoustid-server · GitHub

1 Like

Thanks, that was what I was looking for… you might have mentioned that this whole thread is a duplicate! :slight_smile: Also answers my question about generation (fingerprint vs. acoustID)

1 Like