Newbie warning for Mac: after plugin-installation 1.4.2 worked very bad, 2.0.0 no longer at all

EDIT 24.6.2018:
Update, Summary:

After extended tests (see posts below for details) I can be more specific with my warning: Without having experience with Picard under Windows, it seems that both the “stable” version 1.4.2 and the (beta) 2.0.0 dev6 have serious stability problems under the actual macOS, which even can render the Picard installation unrecoverably corrupt, i.e. which can not be corrected even through a complete dis-installation and clean new installation. When my original post stated “My problem is solved”, then I had been in error.

The final unrecoverable corruption may be correlated to having both 1.4.2 and 2.0.0 on one system, or to having installed plugins which do something bad “behind” in the system… I simply don’t know despite my extended tests.

Through very special luck I was able to revert to a complete system backup, which still had Picard in such a state, so that from this state I could repeatedly do tests about possible ways, how to get to a stable Picard system.

For me this ended up with a sole 2.0.0 dev6 installation, with an updated fpcalc version 1.4.3 for good retrieval performance. With this I am happy again, because I’m anyway doing only manual maintenance of my iTunes mediathek (according to some, the Picard<->iTunes integration anyhow shall be not the best…).

So if anyone comes “fresh” to Picard and/or has not yet ran into problems, I recommend just doing solely this 2.0.0 installation (I find 2.0.0 a tiny tad easier to use than 1.4.2, and with slightly better retrieval performance).

Good luck!
========= Original initial Post: =========
My problem is solved, but maybe my experience can help others. But this needs some explanation of my background:

I’m a Picard newbie/layman currently overhauling a small 4’000 song iTunes mediathek on the latest macOS 10.13.6. I do this album per album, and a week ago I stumbled upon MusicBrainz Picard. WOW! What a great instrument. I do not need automatic iTunes updates, but just to find the information which I then can manually input into the iTunes mediathek, using their “title information” interfaces. Because I liked Picard so much, I also tried the newest 2.0.0 Dev 6, which I found even a small tad better. I stopped my experimental uses of Jaykoz and Yate, because - honestly - I even did not understand how to operate them.

But then - just for curiosity - I installed in Picard 1.4.2 the “Classical Extras version 0.9” plugin. But because I didn’t really understand how to operate this, I simply ignored it.

But somewhat later both Picard versions (1.4.2 and 2.0) appeared to work much worse. I did an uninstallation for both, tried to find implicit system files and purged them as well. Then I did new “clean” installs of both Picards. But now 1.4.2 took a real eternity using “Scan” for “loading album information” in the right half of the UI. Sometimes it took 15 minutes, sometimes it didn’t end successful at all.

Picard 2.0 even didn’t start any longer at all. When I manually started its “Contents/MacOS/picard”, then I got some strange messages in the system terminal…

To cut a long story short: For 2 full days (!) I tried everything again and again, but without any success. Only after finding the related plugin library with Finder and deleting it, I could do a successful reinstallation of both Picard versions. And suddenly everything now ran fine again, like in the beginning. Strange, but true…

Hope this helps any poor soul having run into the same problem…

Where exactly did you find it?

And maybe a hint for windows users:

1 Like

In the folder volume/xyzuser/Library/Preferences//MusicBrainz/ there is a file Picard.ini and a folder Picard.

Deleting the complete folder MusicBrainz did solve my problem.

But when searching with the Mac Finder is difficult (I’m no system crack), one can access it through the App menu MusicBrainzPicard/Preferences/plugins, button “Open plugin folder”.

So apparently the macOS solution is the same or close as the one you mention for Windows.

I think this is not related to the problem. However, if you do want to tag classical music albums fully, then I suggest you use the latest release of the plugin at, read the extensive documentation at and post any queries to this thread: Classical Extras plugin
PS It only currently works with 1.4.2

1 Like

[quote=“MetaTunes, post:4, topic:387234”]

I installed in Picard 1.4.2 the “Classical Extras version 0.9” plugin. But because I didn’t really understand how to operate this, I simply ignored it.

I’m sorry, but I believe I have to contradict:

Out of curiosity I tested again a complete disinstallation of everything (or to be precise: of everything which I could find through App Cleaner and Finder) and then started with:

  1. installing 1.4.2,
  2. installing 2.0.0 dev6
  3. installing in 1.4.2 the predefined “Classical extras 0.9” and activating them.

After this I tested 1.4.2 (fine), then 2.0.0 (also fine). I never consciously touched anything of the plugin (I always only did information retrieval for manual input into iTunes), but of course I don’t know what a 1.4.2 with installed “Classical extras 0.9” does in the background…

Fine, I thought, but my 2nd usage of 1.4.2 ran into a very lengthy and uncomplete scan result: the righthand UI part took very long for “loading album information” (10 minutes or so), and with my 3rd running this even didn’t end at all. 2.0.0 again didn’t any longer start at all.

I disinstalled everything as good as I could, and did a new installations like above. Now both versions, i.e. 1.4.2 and 2.0.0 didn’t any longer start.

Half a day I worked in increasing desparation (I had no longer any working Picard), but nothing changed. For whatever reason…

Thank God, I had a complete system backup of the state where both Picards worked, and because not much else user content had been updated on my actual system, I could go back to this backup. From this state on I repeatedly tried several ways (for about half a day, because just a single backup retrieval cycle took 30 minutes), until I finally ended with a sole working 2.0.0 dev6 Picard, which I even luckily managed to upgrade to the latest fingerprint fpcalc version 1.4.3.

If I should ever again become tempted to try something new with Picard, then I will be warned and will carefully prepare well-fitting backups… :wink:

Did you use v0.9.3 as linked in my earlier post? Did you read the instructions? - particularly the bits labelled “important”? e.g:

It is recommended only to use the plugin on one or a few release(s) at a time, particularly for initial tagging if the “Works and parts” function is being used. The plugin is not designed to do “bulk tagging” of untagged files - it may be better to use a tool such as SongKong for that and then use the plugin to enhance the results as required.

If so, then it is possible to produce custom log files, as described here:

As well as the main Picard log, a custom logging function is provided. This may be either “basic” or “full”. If “basic” is selected, a file “session.log” will be written (over-written each session) to a “Classical Extras” directory inside the same directory as the main Picard log. This gives a processing summary for each release and includes errors, warnings and debug messages if those options have been selected.

If “full” is selected, all errors, warnings and debugs will be written, along with additional debugging messages, to a custom log file for each release processed. These files are stored in the “Classical Extras” directory inside the same directory as the main Picard log. The log file for a release is named using the release MBID. Debugging from these files requires an understanding of the source code.

See the “Advanced tab” section of the readme for more information.

If you want to help debug it (if indeed the plugin is at fault) then I will need a log file and details of the release loaded (only load one release at first - to test it).

Classical Extras will always take about an extra second per track because of the constraints in MusicBrainz over look-ups. There is nothing I can do about this - it is the penalty of getting the extra information.

1 Like

[quote=“MetaTunes, post:6, topic:387234”]

Did you use v0.9.3 as linked in my earlier post? Did you read the instructions? - particularly the bits labelled “important”? e.g:

No, I did not. That’s because I had initially misunderstood the title “Classical Extras”, i.e. I assumed it to be a general “classical” broadbanded utitlity, and not something specializing an analyzing typical information for music of the genre “classical”.

That’s the reason why for my own purposes (retrieving basic information for manually updating my iTunes) I had lost already interest and didn’t want to go to version 0.93.

So all my remarks are not meant critical about your plugin. And anybody including myself must be grateful that people like you do the effort to develop this kind of stuff for the community!

But for whatever reason in my constellation described above the combination of 1.4.2, 2.0.0, plugin 0.9 led to the described very unfortunate effects. For which I now had found a solution…

And thank you for offering debugging help, but as a “classical extras”-non-user I do not need to cause efforts on your side anyway.

1 Like