Needing help with File Naming

Tags: #<Tag:0x00007f6d478b8d30>

Howdy,

I’m a noob at Picard and not having much luck figuring out how do edit/import a file naming script.

I have a duplicate library that I’m experimenting with and would like to build a chronological library
with ‘%date%/%artist%/%album%/%artist% - %title%’ as a sequence (eg. Music/1991/Nirvana/Nevermind/Nirvana - Smells Like Teen Spirit).

My understanding to do that would be to create a new File Naming Script or edit one of the existing ones and save a copy, but I just can’t find a way to do it, I’m not able to edit or create one. Maybe I’m misunderstanding how it works?

I’ve spent the past couple of days reading through this forum but haven’t quite found the answer to my question.

I’m on Picard 2.7.1 on macOS High Sierra.

Any help is super super appreciated :slight_smile:

1 Like

Adding to that, I haven’t had any issues using the Default file naming script, that works fine, just trying to work out how to edit it for a different flavour.

You might want to start by reviewing the Writing a File Naming Script tutorial in the on-line Picard User Guide.

From the File Naming Options dialog, you need to click the “Edit script…” button to open the File Naming Script Editor which is where you can make a copy of one of the preset scripts to use as a starting point, and then make the modifications as required. You can also create a new (blank) script to start with if you prefer.

If you have any questions this is the place to ask, and we’ll try to help.

1 Like

Hi guys,

The same is happing to me. I think it’s a bug in the 2.7 version… I am not able to create nor modify current scripts.

I am using 12.1 Monterrey…Please let me know how I can document this.

Try opening the script editor directly using “Options” → “Open naming script editor…” from the Picard main screen menu (not through the Options screen), and see if that will open it. We were having some issues with it opening behind the Options window and not being accessible on the Mac, it it sounds like this may be a variation of the same issue. Any info you can provide would be greatly appreciated. Information on general troubleshooting and providing information is available through the General Troubleshooting page in the Picard User Guide…

Thanks @rdswift
I made this short video to explain the issue. Please let me know if you can view it:

https://1drv.ms/v/s!AsRTe15-3kVzh6I46f8K_MFuua8Pag?e=ZBfqLH

@JuanraNunez, I had misunderstood the original issue, so your video helped a lot. Thanks for that.

This is a simple one to explain (and fix). You can’t edit a “Preset” script. They are read-only. What you can do is either make a copy of it using “Script” → “Copy the current script” from the menu bar in the script editor, or start a new blank script using “Script” → “Add a new script”. Both of these will create a new “User” script that you should be able to edit at will.

Many thanks @rdswift!

That was very helpful. I hadn’t noticed that the menu changed when the script window was opened.

Regards.

1 Like