Is slow for anyone else?

For a few days now MB is really slow for me. Especially when loading edit search results.
I haven’t changed anything in my browser configurations regarding MB.
Does anyone else experience this?

E.g. try this link:!%3D&conditions.3.args=314&conditions.4.field=type&conditions.4.operator=!%3D&conditions.4.args=315&field=Please+choose+a+condition

Usually it takes like 2-5 seconds to load it, now it takes about 15 seconds regularly

From my side, I didn’t notice any slow.

I’ve noticed that some, though it doesn’t seem to be consistent

1 Like

You have two edit type conditions instead of one (it’s a multi-select), but I don’t know if it changes your speed.

You are making a big search, maybe try to limit time span to created after last month, maybe?

I did not really notice any particular slow downs in my usage.

1 Like

This really does make it faster, thanks. Still something must have changed with the search function, because the old search was never this slow before.

Do you get the same speed issues in different web browsers? What about Privacy Mode with all the addons disabled as a test? Could be something having temporary hiccups.

MB isn’t slower than usual afaik. But this query for sure is.

@yvanzo any idea ?

1 Like

Firefox 68.0b8, cache disabled, usual extensions and userscripts enabled:
Finish: 5.45 s (original, two edit types)
Finish: 5.49 s (one edit type only)
Finish: 5.30 s (one month limit)

Sometimes it takes ca. 3 s

1 Like

I does not sound strange to me. Once your edit search is computed, you go through pages faster.

This is getting stranger and stranger.
I’m in the garden right now - admittedly not the best spot for receiving the wifi signal and any MB page takes 2 minutes and sometimes longer to load while all other websites load fast.

PS: Just tried with a hotspot: same result. So it’s not the network.

1 Like

Got this just now. When I tested your link yesterday it seemed to be alright.



Yeah right now there seems to be something going on with the server and the extreme slowness I experienced before seems the have been a precursor.

Just got the same thing with Picard authorization… :frowning:

aaand it’s back up again :slight_smile:


Ditto, it wasn’t loading for me earlier

We had a search server failure, which had bad impact on MB web server. Everything is back to normal.


The whole site has been either slow or unavailable for me all day.

It’s been quite slow today with some errors while searching for entities.

Can’t connect to (Connection timed out)
Connection timed out at /home/musicbrainz/carton-local/lib/perl5/LWP/Protocol/ line 50.

EDIT: It seems like the error only occurs when I use indexed search. Using direct database search doesn’t seem to bring up the error.

1 Like

Yes, SOLR cloud is very unstable, I’m on it. Sorry for inconvenience.