How to unset the acoustid_id and prevent to store it into files?


#1

I don’t want that Picard writes the id3tag “AcoustID ID” into my files.
Whatever I try in Options -> Options -> Scripting it doesn’t prevent it.

Unsuccessful:
$unset(acoustid_id)
$unset(acoustid)
$set(acoustid_id,)
$set(acoustid_id,’’)

What else can I try?

BTW: Other unwanted id3tags get ripped away smoothly…:thinking:

PS I found this ticket:
https://tickets.metabrainz.org/browse/PICARD-419
It seems to be closed and for Mac OSX only.
Should I reopen it for Environment Windows?


#2

It was closed because it is a duplicate of https://tickets.metabrainz.org/browse/PICARD-268


#3

Picard 268 is closed too :face_with_monocle:


#4

Ah :slight_smile: Now I see it.

The correct tag name is acoustid_id, and there is also acoustid_fingerprint. Does this work?

There is always https://picard.musicbrainz.org/docs/tags/ if you are unsure how a tag is named. And also the more technical https://picard.musicbrainz.org/docs/mappings/ , which shows which tags are supported for which metadata format (ID3, Vorbis etc.) and how it is stored.


#5

Thanks, but as I already wrote in my initial post $unset(acoustid_id) doesn’t work.

If the ticket is closed, where can I find the fix itself and the Picard version including this fix?


#6

The issue seems to be that acoustid_id is metadata only found in the file, it is not metadata Picard loads from MB.org normally. That means scripting has no affect on this.

The scripting is applied for data loaded from MB.org, that is the data on the right pane. The acoustid is only inside the file. There is some special handling in Picard, that handles that the acoustid from the file is kept around when a file gets matched to loaded metadata on the right pane.

So scripting is currently out of the equation here :frowning: Just to verify a few options: Does it work if you delete the tag manually from the files (select the files, right click the tag at the bottom and choose “Remove”)? Does using the “Clear all tags” option work (be carefull with this one when testing, it will really remove all tags and write only the tags shown in Picard to the file)?

If these two things work I would suggest adding a new ticket to request specifically being able to unset the acoustid_id using scripting. I currently don’t know for sure how this can be fixed, but the scripting probably needs to be extended to apply to more cases. Now that Picard actually supports having mutliple separate scripts there could also be some optioin to specify when and on what data a script gets applied (e.g. on metadata loaded from MB, on file metadata when a file gets added, applied just before saving a file).


#7

Actually, you can access file metadata from 2.0dev4 onwards.


#8

Sorry, but this can’t be the reason in my case. I am 100% sure, that there is no acoustid inside my files. I double-checked it with Mp3tag, there is nothing like this in the ID3 tags if I load the files to the left side of Picard. In the details view I can not see any acoustid information as long as the files are on the left side, unmatched or clustered.

BUT:
As soon I press the Scan-Button, the acoustid is displayed in the details view.

And this seems to be the problem: I can’t force Picard to discard this value.

What I found:
If I manually remove this tag from the selected files on the right side with a right-click -> REMOVE then they will not be saved to my files.

Using “Clear all tags” deletes the Lyrics, Comment, Genre and some of my own tags BUT NOT the acoustid.


#9

Here you have it, the scan button will generate the acoust ID. And this is still done on the file metadata. Exactly the same issue as if it would be only loaded from the file.

Please try the latest Picard beta, as @samj1912 suggested, and see if the unsettings works there.


#10

After installing Picard 2.0.0.dev5 the command $unset(acoustid_id) command works for me, no more unwanted “AcoustID Id” in my files. :+1: