How fast should clustering work?


#1

Hello All!

I used Picard to help organize my parent’s MP3 collection, and it seemed to work pretty well in Win 7.

On my computer though, I selected 10 files from the same artist and clicked the Cluster button, and it took about 3 mins to complete the clustering on them. Is this out of the ordinary? That seems way too long to me, but wasn’t sure what was involved with clustering.

I’m using Win 10, and started Picard as an administrator to see if that made a difference (which it didn’t seem to). I temporarily shut off Windows Defender’s real time function since it seemed to be competing with Picard for CPU cycles.

I searched a bit and didn’t see any complaints about slowness when clustering (only when saving)…any suggestions?

Here is the detailed debug log:
I: 07:39:50 Plugin directory ‘D:\Program Files (x86)\MusicBrainz Picard\plugins’ doesn’t exist
E: 07:40:01 Cannot load image from u’D:\Users\Public\Music\Aaron Neville\Tell it Like Is Single\07 Tell it Like Is.mp3’: Not enough data
E: 07:40:16 Cannot load image from u"D:\Users\Public\Music\Bo Diddley\I’M A MAN\02 WHO DO YOU LOVE.mp3": Unrecognized image data
E: 07:40:46 Cannot load image from u"D:\Users\Public\Music\Chiffons\The 60’s Greatest Hits\13 Da Doo Ron Ron.mp3": Not enough data
E: 07:40:47 Cannot load image from u’D:\Users\Public\Music\Chuck Berry\One Dozen Berrys\09 Rock and Roll Music.mp3’: Not enough data
E: 07:44:36 Cannot load image from u’D:\Users\Public\Music\Sam Cooke\Greatest Hits\12 Cupid.mp3’: Not enough data
E: 07:45:12 Cannot load image from u"D:\Users\Public\Music\Stevie Wonder\Up-Tight\06 Uptight (Everything’s Alright).mp3": Unrecognized image data
E: 07:48:14 Cannot load image from u"D:\Users\Public\Music\WHEN IN ROME\Top 1000 Pop Hits of the 80’s\07 THE PROMISE.mp3": Not enough data
W: 08:01:38 Not enough data, skipping Image from http://ec1.images-amazon.com/images/P/B001F5M9MG.01.LZZZZZZZ.jpg
W: 08:01:39 Not enough data, skipping Image from http://ec1.images-amazon.com/images/P/B001F5M9MG.01.MZZZZZZZ.jpg
D: 08:15:41 Debug mode on
D: 08:15:55 Clustering [<File u’01 Dimension.mp3’>, <File u’02 White Unicorn.mp3’>, <File u’03 Woman.mp3’>, <File u’04 Where Eagles Have Been.mp3’>, <File u’05 Apple Tree.mp3’>, <File u’06 Joker & The Thief.mp3’>, <File u’07 Colossal.mp3’>, <File u"08 Mind’s Eye.mp3">, <File u’09 Pyramid.mp3’>, <File u’10 Witchcraft.mp3’>, <File u’11 Tales.mp3’>, <File u’12 Love Train.mp3’>, <File u’13 Vagabond.mp3’>]
D: 08:15:55 Moving <File u’01 Dimension.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:16:08 Moving <File u’02 White Unicorn.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:16:21 Moving <File u’03 Woman.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:16:35 Moving <File u’04 Where Eagles Have Been.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:16:51 Moving <File u’05 Apple Tree.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:17:11 Moving <File u’06 Joker & The Thief.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:17:24 Moving <File u’07 Colossal.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:17:39 Moving <File u"08 Mind’s Eye.mp3"> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:17:52 Moving <File u’09 Pyramid.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:18:06 Moving <File u’10 Witchcraft.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:18:20 Moving <File u’11 Tales.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:18:37 Moving <File u’12 Love Train.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>
D: 08:18:52 Moving <File u’13 Vagabond.mp3’> from <Cluster u’Unmatched Files’> to <Cluster u’Wolfmother’>


#2

I can’t read debug logs sorry, but I’ve had issues with really big files before (massive embedded images in each track).
Something to check?


#3

The only thing the log output above really shows is the time it took for the files to get clustered (about 3 mins), and that there were no errors when clustering. I checked all of the file sizes referenced in the log and they’re between 5MB to 8MB…so nothing too large. Thanks though, @aerozol.


#4

I have w10 and clustering is very fast. Maybe something else going on on your PC?


#5

There must be, but I can’t figure out what. I’ve disabled Windows Defender, shutdown my backup program and google music which monitor the mp3 directory, and I’ve been using the task manager for stats. No other CPU cycle hogs, memory is around 50%, and the disk isn’t being written to until I save. I’ve also run Picard as admin. It’s strange.

Anyone have more ideas to check, or tricks to attempt?


#6

How many files have you tried? Does it affect all files, regardless of the folder they’re in or how many files are in the folder?


#7

I’ve had similar problems I was able to trace to corrupted graphic files. Perhaps something to look at.