How can I prevent picard from creating separate folders for each disk in an album?

musicbrainz
style
picard
Tags: #<Tag:0x00007f23c2a79d50> #<Tag:0x00007f23c2a79b70> #<Tag:0x00007f23c2a798f0>

#1

My current naming convention is

$if($ne(%albumartist%,),%album%/)$if($gt(%totaldiscs%,1),%discnumber%-,)$if($ne(%albumartist%,),$num(%tracknumber%,2) )%title%

and this is making picard create folders named Album name (disc x). I would like to have these all in the same folder, with just the album name.


#2

I think it should work if you just removed the “$if($gt(%totaldiscs%,1),%discnumber%-,)” part. Did you make this file naming string yourself or did you just copy it from somewhere else?


#3

Removing $if($gt(%totaldiscs%,1),%discnumber%-,) didn’t help. In fact, it introduced a new problem. Previously, albums with multiple disks were named disc number - track number. So for the 5th track of the second disk, picard would name it 2-5… this is what I wanted. By removing $if($gt(%totaldiscs%,1),%discnumber%-,), the same file is now named 5… without the disc number. And picard is still creating two folders, one with all the tracks from disc 1 and another with all the tracks from disc 2.

I copied it from somewhere else and messed around with it until it gave me the results I wanted. I don’t actually know the syntax.


#4

This is really odd. I’ve tried with your file naming string, and here the disc number doesn’t end up in the directory name. And looking at your file naming string, “$if($ne(%albumartist%,),%album%/)” should be the part that creates the directory, and the disc number doesn’t feature there at all. Are you sure the disc number isn’t a part of the release title (this used to be common practice on MusicBrainz, so the release you are trying it with might be from that era)? Could you post a link to the release?


#5

This is one of the releases that is giving me problems: http://musicbrainz.org/release/816cfa5f-ba76-4916-b5f3-8acb82314c3c?tport=8000

I’m sure it’s not part of the release title. It shows up as one single release in picard. But it gives me two folders named

「ダンガンロンパ The Animation」オリジナルサウンドトラック (disc 1)

and

「ダンガンロンパ The Animation」オリジナルサウンドトラック (disc 2)

respectively.


#6

Do you have any tagger script setup in advanced options? Or do you have the Classic Disc Numbers plugin installed and active? That plugin would do what you described.


#7

Yes, thank you. Turning off classic Disc Numbers fixed it.