HELP! Can't save files or acces Preferences

Tags: #<Tag:0x00007f05094fbe78>


Afternoon, I was using MusicBrainz fine last week, but now all of a sudden when I use it, I can’t access ‘Preferences’ nor can I save anything, so it makes MusicBrainz worthless to me now. Can anyone help? Oh and I’m using a mac if that makes any difference.



Do you mean the MusicBrainz website or the MusicBrainz Picard tagger application?


I mean the MusicBrainz Picard tagger application on the Mac…


Are you using an older version or the latest? I know there had been issues in the past where a broken tagger script prevented the preferences from opening.

Also look if there is any output under Help > Show Error/Debug Log after you tried to open the preferences and paste that output here. Maybe we can see the issue then.


Sorry to necrobump, but I’m having a similar issue. I too use Picard on OSX, and I can save files with it but I can no longer access the Preferences menu (or the “About MusicBrainz Picard” function, so I cannot tell which version I am running).

Here’s the output from “Show Error/Debug Log”:
W: 02:18:11 Plugin directory ‘/Applications/MusicBrainz’ doesn’t exist
E: 02:18:11 Plugin ‘coverart’ : Traceback (most recent call last):
File “picard/plugin.pyo”, line 292, in load_plugin
File “/Users/[name]/.config/MusicBrainz/Picard/plugins/”, line 36, in
ImportError: cannot import name mimetype


The version is outputted in first lines of the debug log when you start picard with -d option.


How do I enable that option? The Preferences menu is inaccessible.


@HibiscusKazeneko: from command line, see


I 'm having difficulty figuring out how to get the command line thing to work, but I did manage to get the version name from the “Get Info” option in Finder:

EDIT: Here’s the debug log:


Delete the file /Users/Rachel/.config/MusicBrainz/Picard/plugins/, then it should start.

This is an outdated plugin no longer required by Picard (cover art support is built in) and it is no longer compatible with Picard. It would be nice if Picard would handle such situations properly.


I just got rid of that file and relaunched the application, and I still can’t access Preferences.


If you removed that file, but it still doesn’t start, you should get another error message, please let us know.

I wonder why you suddenly started to have issues, did you upgrade something ?


I don’t know. I had issues with this new version of Picard from the outset. I had to temporarily disable a security feature to launch it the first time because it was showing up as unsigned; then I re-enabled said feature and have been able to run the application since (I’m unsure if something got lost in transit). I can’t recall opening the Preferences or About windows since the upgrade, so this might have been bubbling under the surface this whole time.

Here’s the new error log:
W: 03:41:15 Plugin directory ‘/Applications/MusicBrainz’ doesn’t exist
E: 03:41:15 Plugin ‘coverart’ : Traceback (most recent call last):
File “picard/plugin.pyo”, line 292, in load_plugin
File “/Users/[name]/.config/MusicBrainz/Picard/plugins/”, line 36, in
ImportError: cannot import name mimetype


It means you didn’t remove the file as requested by @outsidecontext


I did. I’m looking at the folder in Finder now and the file is not there.

EDIT: I relaunched in debug mode and the plugin in question is no longer mentioned. Here’s a new Pastebin:

EDIT #2: I removed coverart.pyo and it still didn’t make the issue go away. In generating the log for this Pastebin ( I noticed that the log took a long time to generate and a long time to close. I wonder if there’s some connection…


The log you posted shows the coverart plugin issue is gone.
Try to open Preferences, and see if an error is logged


I just attempted to open Preferences and looked at the log right after; all I get is a repeat of the last line showing a chain of cover art sources.
EDIT: Same deal with the About menu too.


I have the same issue, unable to open preferences - though it worked fine in the last few days. I have not file ending .py to delete. In attempting to troubleshoot I upgraded to the 1.4.0dev5 for OS X. Sill no joy

W: 19:19:10 Plugin directory ‘/private/var/folders/wf/t0bm0n1j0fv_fxd4s4tzm5hc0000gr/T/AppTranslocation/2F33680F-B1DF-4902-B79C-2338DDBF98D8/d/MusicBrainz’ doesn’t exist

The log suggests I’m missing something?


That’s just a warning, saying this directory doesn’t exist, plugins used to be there, but aren’t packaged anymore. It should be without any negative impact.


That’s really strange, is there for sure no other output in the logs after you tried to open settings? In the past issues like that were caused by some error in handling existing settings.

Apart from that I would suggest removing existing settings and start a clean setup. Not quite sure how to remove the existing settings on OSX, @zas?