Forums are about to be migrated to new server

Forums will be set to read-only in order to perform migration to a new server.
The whole process is expected to last for one hour or less.

Emails will be disabled too during the process.


Migration is mostly done, it was slower than expected, sorry for that.
For now, emails are disabled, I’m running few maintenance tasks, full functionality will be restored very soon.


Migration fully done.
Some images may still missing, but a background task should take care of that within next hour.

Please report any issue.


Stylesheet (CSS) issue

Now when I scroll down inside a topic, the top header toolbar gets 98% out of the screen on mobile.
And the post edit bottom buttons are also going off screen.
Android 9 Kiwi.

What versions of Discourse did we upgrade from and to?

There are no such problems on latest inside topic.

From 2.8.14 to 3.1.0.beta2

1 Like

I opened a support topic at meta:

@Zas, could you add #discourse tag here?
I cannot edit #sysadmin topics. :grin:

1 Like

Done :wink: I unlocked the initial post.

1 Like

The problem stopped for me, now!?

Some old CSS and/or JavaScript must have put some time to update in my browser cache!


It seems to only occur sometimes, assuming we are seeing the same thing. It’s also not a fixed amount, sometimes more, sometimes less.

We are seeing different things it seems


@zas Discourse 3.1 styling broke the formatting of cover art images in the MusicBrainz Oneboxes (images are rendered rather tiny). I put out a fix with Release v0.15.1 · phw/discourse-musicbrainz-onebox · GitHub

1 Like

Slightly annoyed that formatting options like “preformatted text” or “list” are hidden. They used to be directly in the toolbar

Worse yet, it seems the keyboard shortcut to preformat text seems to no longer work (IIRC it was CTRL+E). It’s not shown in the tooltip either unlike the other options.

That’s odd, for me it looks like this:


What did Ctrl + E do? If I press this it does create this:

type or paste code here
1 Like

Doesn’t do anything :sob:

Also tried clearing cache and incognito mode so I don’t have to delete my precious cookies or manually disable extensions. Same issue. FML

This is on Chrome 109 BTW, nothing of relevance in browser console either.

Edit 2:
Tried Discourse safe mode to no avail.
But weirdly enough on a different device (notably larger screen) with the same browser I have none of these issues.

No idea what’s happening here. Tried it with both Firefox and now also Chrome, looks the same to me. I also can’t see any user preference to change anything for the editor.

I even looked into the local Discourse install I have to check if there is any site-wide configuration in the admin section of discourse, but even there I don’t see options to configure the editor buttons. Not sure if the MB forums run anything special here, @zas?

Thanks, onebox v0.15.1 deployed.

1 Like

It appears when you have a touch capable screen it behaves similar to mobile view and hides options:

My output of Discourse.__container__.lookup("capabilities:main");

    "touch": true,
    "isAndroid": false,
    "isWinphone": false,
    "isOpera": false,
    "isFirefox": false,
    "isChrome": true,
    "isSafari": false,
    "isIpadOS": false,
    "isIOS": false,
    "isApple": false,
    "hasContactPicker": false,
    "canVibrate": true,
    "isPwa": false,
    "isiOSPWA": false,
    "wasLaunchedFromDiscourseHub": false,
    "isAppWebview": false
1 Like

Oh no, you are right, small zoom in still happens and also header and post edit buttons off screen. :thinking: And not on meta.

No problem on try, no problem on meta.
Only here and only since the upgrade… :thinking:

Got a userscript solution for the touch device detection problem:

Fork with predefined useragent strings:


dodesz found that it was because of long tags in the Suggested Topics!
They will work on it, probably.
They don’t have long tags, like us.