File naming syntax

filenaming
Tags: #<Tag:0x00007fe3d11c38f8>

#1

HI there. I used piccard before my disc chrashed and was naming my mp3 in the folloving manner.

Artist (Offsping, The) / Year of Album - Album Name / Disc number (CD1)-Track Number - Track

Cant put together simple naming procedure again.
Can somebody help me please?


#2

Try the following:

$if2(%albumartistsort%,Unknown Artist)/$left($if2(%date%,0000),4) - $if2(%album%,Unknown Album)/$if2(%media%,CD)$if2(%discnumber%,1)-$num($if2(%tracknumber%,1),2) - $if2(%title%,Unknown Track)

I think this will do what you want. Note that I padded all of the track numbers to 2 digits so that they sort properly.


#3

rdswift, thank you big time. Simple and enough for my needs.


#4

You’re very welcome. Just glad I could help.


#5

That’s just about what I would have done as well. The only difference is that I would have made a note that as you have it, it can occasionally create some awkward numbering (Digital Media1). If you’re worried about that, the easy fix is to put a space between the ) and the $ immediately after the CD, but that will affect CD 1 as well.

If you do want to keep CD without a space while adding one after Digital Media, the issue is probably that multiple words don’t look great with the number being suffixed to the final one, and so the solution would be to only add the space if the medium type also contains a space; put the following between that same )$ instead, without any extra spaces to either side:

$if($in(%media%, ), )

#6

thakns both I tried a bit different thru reading more…but… error in somealbums which I want to arange…
E: 20:31:38 Traceback (most recent call last):
File “picard\util\thread.pyo”, line 46, in run
File “picard\file.pyo”, line 172, in _save_and_rename
File “picard\formats\id3.pyo”, line 424, in _save
File “picard\formats\mutagenext\compatid3.pyo”, line 114, in save
IOError: [Errno 13] Permission denied: u’C:\Users…

Any ideas what would that mean? It happens when I try to save after “lookup” with sign for one way street in right window before tracks…
confused :S


#7

At a quick glance it looks like Picard was unable to write to the destination folder. Check if the folder exists, you have write access to it, and that the file that you’re working with isn’t read-only.


#8

I’m not sure what the rest of the log is, but when I run into issues saving it’s because I have the file playing in another program. Sounds like this might affect everything in the album, though, so that may not be what’s wrong in this case.


#9

not know how but partialy was readonly…solved the case.
Thanks