Error while setting up bookbrainz database server

it is looking for a file which i don’t have Maybe I am missing something . please help me.

That’s an error I’ve never seen, so I’m not sure if I can help much.
The first thing I would do is restart the computer and try to build again, see if you get the same error.
I need a bit more context if I’m to help: what command were you running? What version of docker and docker-compose are you using? If you re-run the command, does it fail with the same message?

I believe the issue is with docker or docker-compose rather than with anything to do with BookBrainz, considering it seems to successfully build the image.

It looks like this is the same issue you’re having, I’d recommend following it to see how it develops:

It might also be worth updating docker and docker-compose, in case it’s an issue that has been solved in a newer version.

That’s all the ideas I have for now. Good luck with the bug hunt !


just successfully done the setup . I just updated my docker version and rebuild again . Thanks a lot . Looking forward to understand the codebase.Please give me some suggestions to understand the codebase quickly @mr_monkey

1 Like

Success! :tada:

As for the codebase, the main question is: what part are you most interested in?
There are front-end React components, and the server is written in Node/ExpressJS. Each has its own folder.

Paradoxically, using the website and entering data also helps understand what the different front-end components are and what they are used for.

In my opinion, the best way to start is to pick up a “good-first-bug” ticket from our issue tracker, discovering one small piece of the codebase at a time.


Not able to run api .
Command used ./
node version = v15.9.0
npm version = v7.5.3
gives following error

Thanks for reporting this :slight_smile:
The error should now be fixed, please try to pull from the git repo and try again.

1 Like

from last 1.5 hours(90 min) It is not showing any progress.It is stucked at this position.
Should i wait more?
I am running ./ . I am assuming it is not finished yet as localhost:9099/1/api-docs gives no result.
Internet Connection is also fine. There is no chance of Bad network.

Also i built the database required for testing . But there is no instructions of how to run them?

1 Like

Thanks, there’s another error that snuck in, and that’s one problem.
Something missing in the docker-compose.api.yml file.
I just pushed a fix for that.

The other error is in the documentation. The api is running on port 9098 and the readme points to the wrong port. That’s corrected now, sorry about the waste of time!

After pulling and running again, try hitting localhost:9098/1/api-docs.