Error of WebService

Tags: #<Tag:0x00007f7d01744de0> #<Tag:0x00007f7d01744ca0>

I have error 503 {“error”: “The MusicBrainz web server is currently busy. Please try again later.”} on request to WebService
Yesterday there was a limit on requests x-ratelimit-limit: 1200. And I could do 2-3 requests per second. I’m developing an android application for MusicBrainz and this was enough for me. But now limit on requests x-ratelimit-limit: 200. And now I can not do even 1 request per second. This is terribly slow and makes it impossible to further develop the application. I hope that the limit will be returned to at least 1200. Ideally it would be 2000, but now it looks incredible.

Hi, very recently we’ve been having issues with increased database server load which has been causing huge slowdowns across all our projects, we’re looking at reasons as to why this might be happening, but in the meanwhile, we’ve reduced the ratelimit temporarily in order to allow the services to recover and function at least. This is temporary and we’re working on finding the cause for this, we’ll probably go back to original ratelimits as soon as we fix it.


Thanks for the information @iliekcomputers. Some kind of banner/status on the main page would help :wink:


Was wondering if the new Windows update broke something in my network settings. Glad to know it is on your end in this case. :slight_smile: