Don't remove album number

filenaming
scripting
Tags: #<Tag:0x00007f3097eb0068> #<Tag:0x00007f3097ea75f8>

#1

Hi, i have several albums where the numbers are correct, but not the names’s.
How can i make MusicBrainz understand that it should leave the album numbers alone, and only change the name and album name.


#2

You’ll have to be more specific than that. What’s an “album number”? Can you provide an example of what you’re talking about with links to the MB release page?


#3

Are you using Picard to tag or trying to edit on the Musicbrainz website?


#4

Well, i have a cd Top 100 of Disco with 5 CD’s.
Every CD has 20 tracks and are numbered from 1 to 20.
The name of the records are wrong and have to be corrected.
But the numbers have to stay. Can i do that?


#5

I’m still not 100% on what you’re talking about. A specific example with links might help.

If you mean the track numbers, yes they stay the same unless you change them.

If you mean the ordering of the CD’s, that will also stay unless you change it.


#6

(I am assuming you are using the musicbrainz website
https://musicbrainz.org/
Not Picard.
If this is not so then the following will not be very helpful.)

Is the Release you have very close in appearance to this one?

If yes, the order of the CDs currently in Musicbrainz database match the order of the CDs as shown on the tracklist cover art at


Which would mean the current order of CDs is correct for that Release.
Are you saying that track titles need to be corrected?


#7

@kurt5 can you clarify about what the question is? Are you trying to correct a release on the MusicBrainz website or do you look for a way to correct your local files? If the latter: You can use e.g. Picard to rename your files.


#8


This the CD


#9

This my folder, after tagging with musicbrainz picard


#10

Please show us your file naming script (see Options > File naming). It needs to set the %tracknumber% in the script.

If you use the default the issue likely is happening when you just save your local files and those don’t have an album artist set. Please see the following answer on you to fix the script:

Are you actually tagging your files against MusicBrainz metadata (by looking up your files on MusicBrainz and saving the results on the right pane) or are you just manually updating and saving your tags in the left pane? If you don’t know what I mean take a look at the Quick start guide


#11


#12

In this case set %tracknumber% at the start, e.g.

%tracknumber% %artist% - %title%

Or if you want numbers with leading zeroes (01, 02, 03, …) then use:

$num(%tracknumber%,2) %artist% - %title%

#13

What I do in my script, to deal with multiple disk releases:

$if($gt(%totaldiscs%,1),%discnumber%,$noop())$num(%tracknumber%,2) - %artist% - %title%

In the first part, I check if %totaldiscs% is more than 1, and if so, I prepend the disc number to the track number, so the third song on the first disc would be: “103 - artist - song.mp3”, while the third song on the fourth disc would be: “403 - artist - song.mp3”.

BTW, I still can’t find the release in MusicBrainz. Looking at your two images, it looks like you’re connecting to different releases than the one you want. Are you using “Scan” to locate the songs in Picard? If so, Picard is probably connecting your songs to several different collections in the database. The best course of action, if you want to preserve the structure of your release, is to add that release to MusicBrainz and then tag your files with that information explicitly.


#14

Since i’m new to musicbrainz, i still have a lot to learn. Also, how to add an album.
But by using the program i will.

But i would like to see my songs like this.
image


#15

Beginners’ Guide
How to add a release