Direct search for new Place not functioning


#1

I’ve added 2 new places.
Mitchells Plains:
https://musicbrainz.org/place/fd7c289b-c695-4f5f-9a4c-f620ac1e781b
District Six:
https://musicbrainz.org/place/1102f079-5d76-43a4-bcab-56eaf3cc1319

When I try to use them in relationships they are not found. Even with Direct search.
Nor are their URLs recognised in the place box.

Database problems?


#2

For how long have you waited? Did you try to use this “1102f079-5d76-43a4-bcab-56eaf3cc1319” part for search query in relationships editor, but not the actual name? (This is the way to avoid wrong relationships by the way). As I am concerned, it takes about 2-3 hours for DB to index new entries.

[edit] I have tried already, I can find this entry through the ordinary indexed search query. Maybe the problem on your side?


#3

Pro tip™: Paste the full url is even better as it is faster to copy and as when pasted autoselects the according entity type, no need to change it prior to paste.


#4

Issue persists here.
Tried Chrome browser this time . (Firefox last time.) Both current versions on Android.

Putting new Places into Artist: Edit: “Born in” \ “Died in” there is:
No return from Direct search
Nor from indexed search.
No “Add place” offered.
No recognition of URL for new Place.


#5

Strange indeed.
I myself often have to reload pages because of incompletely loaded JavaScript.
But my network is really bad.
Maybe this?


#6

Your example place URL works in a relationship editor popup but not in artist begin/end fields indeed, although other place URL do work in that fields.

You should create a bug ticket.


#7

This field only accepts Area entities, not Places.

Which one?


#8

This sounds as if the process for getting an Area entity added would be like that for getting an Instrument entity added.
Do I just submit a ticket?

Basil “Manenberg” Coetzee being born in “Cape Town” and dieing in “Western Cape” is about as accurate as having; Jimi Hendrix (stringed instrument player), and J.S. Bach (keyboardist) - which is to say, misleading.


#9

Pretty much the same, yes, only under the Area Request (AREQ) project


#10

Oh and this is what I suspected but I tested it wrong.
It’s a no issue.


#11

I’m thinking that with historical changes to Area names being collapsed into the current names, Coetzee will be “born in Cape Town” for a while yet.
Oh well.


#12

I’ve filed Area requests for both places:
https://tickets.metabrainz.org/browse/AREQ-1673
https://tickets.metabrainz.org/browse/AREQ-1674

I also made edits to have the Places removed, since that should really be Areas (if we want them at all):
https://musicbrainz.org/edit/48745182
https://musicbrainz.org/edit/48745254


#13

Thanks Fresco. Mitchells Plains would appear to make sense in the current way Areas are handled.

But District Six is no longer called District Six and so is like USSR, Deutsche Democtratische Republik (East Germany) and Prussia and doesn’t fit into the current Area scheme.
(Unless I’ve missed something and historical Areas are now supported.)