Cover Art Load Issues

cover-art
musicbrainz
picard
Tags: #<Tag:0x00007f23c2cf7cd0> #<Tag:0x00007f23c2cf7b18> #<Tag:0x00007f23c2cf78c0>

#1

I added some releases and then added some cover art, but something appears to be broken.

Here are some examples:




For these above, the front cover shows up and a back for one of them, but none of the other images show up even though you can click the “original” links and they come up, so I know the upload worked correctly. They were uploaded a couple of hours ago.

I have a feeling it could also be a related problem, but if you load the following two into Picard, the front image can’t be loaded because Picard can’t find the JSON file.


Does anyone know what’s going on? Should I wait longer?

I think I broke the cover art archive. :stuck_out_tongue:


#2

I’m not sure how it interacts with the JSON, but the CAA does sometimes take a while to process images – if it’s under a big load, several hours is easily in the realm of possibility. If they still haven’t showed up in a day or two, then I’d start wondering if something had happened, but until then I’d just put it down to the server being busy.


#3

Looks like you’re right… Things are starting to show up now.
I should have waited longer. :blush:


#4

I’ve had some that have taken two weeks or more before the 250 and 500 px thumbnails were generated, even though other files I uploaded during that period appeared right away. I have no idea how the CAA processes its backlog, because there doesn’t seem to be any pattern that I can discern.

In every case so far regarding my uploads, if I waited long enough eventually they showed up.


#5

Judging by the newly opened CAA tickets, I’d say there is something going on. Also 3 of my additions are still not shown after 3 days: https://musicbrainz.org/user/culinko/edits/open.


#6

It’s even weirder than that. Right now, I can’t see the cover art to this release, even though it showed up when I first added it, six days ago.

But I can see all the cover art from this release, including the ones I uploaded last night.


#7

I can see the cover art for the release you linked just fine, same for your edit from 6 days ago: https://musicbrainz.org/edit/47066483.


#8

So it’s even more inconsistent than I thought.


#9

Huh, that is indeed very strange.


#10

Did you try clearing your browser’s cache?


#11

I’ll try that next time it happens.


#12

I uploaded a bunch of artwork about a week ago to https://musicbrainz.org/release/2e33fd6d-9562-4efd-bd58-1693e6215b6b/cover-art and so far only the first image shows up. I tried clearing my browser cache as you suggested but I still don’t see the rest. Do you see them all or are the last 7 still shown as unavailable?


#13

They’re not available yet.


#14

Okay, thanks. Like I said earlier, my experience is that eventually they will show up without any intervention on my part. Then again, I suppose that could be a happy by-product of intervention by someone else to address their issues… :slight_smile:


#15

There are some bugs reported like https://tickets.metabrainz.org/browse/CAA-99 and https://tickets.metabrainz.org/browse/CAA-100