Can't save tracks, can't find instructions

New user trying to work all this out, but keep running into th same problem in that only one or two tracks gets saved when I click to save an album.

I think I’ve done everything correctly to that point… drag the folder of tracks onto Picard, click cluster, then lookup’. Everything appears correct, complete tags down the right-hand column for each track… click save and I get one green tick and everything else is a stop-sign… tho the mouseover tooltip says ‘excellent match’.

Trying to save individual tracks doesn’t do anything either. I’ve checked my Windows user account and the system account both have full permissions on the directory with the tracks in it, so not sure what else to try.

Checked the forums for the last half hour trying to find some help, but while it seems a lot of people have similar issues saving files, there’s no solutions offered that have helped me, so any suggestions much appreciated!

Thanks!

The sense that I make of this description is that Picard finds only one music file that it can tag in the folder that you have dragged across.
I would check that;
there is space on the disk for new data to be added,
that those untaggable files are functioning audio files and that they play.

If that doesn’t help then post here with the version of Picard you are using and your OS and the type of audio files (mp3, flac etc) & someone with better technical skills than me will turn up.

Thanks mmirG, but it is finding the whole album and telling me it has an excellent match for each track. It’s also adding all the tag info in the right-hand column, but just won’t let me save all the tracks after that.

I click save and only one gets saved… the rest have the dark circle with a horizontal line. So that looks like some sort of error or warning, but the mouse-over tooltip says ‘excellent match’, so that’s a bit confusing too!

Using windows 10 and these are mp3 files…

thanks in advance…

Problem solved… for anyone having similar issues…

When I checked permissions on my ‘music’ folder, I’m thinking I must have checked an alias without realising it. The actual folder… and all the album/artist folders inside it were all set as read-only.

So checking the picard debug log showed repeated permissions errors… checking individual folders confirmed it, and updating settings for the top level directory and all sub-folders corrected it.

6 Likes