Can't add tracklist to newly made releases


#1

Hi, I was just adding some releases and for some reason the tracklist doesn’t appear, I tried editing the release and adding the tracklist again but same thing happens: “The tracklist for this release is currently unknown”. That is going on with every single release I create since a few minutes ago. Can anybody help me figure it out?

Links for the releases: 1 | 2


#2

When I edit it I see a check box saying the track list is unknown.
If you unchecked this you should then be able to create a medium and add tracks to it.

I see you are a new user and are currently a limited user.
You will become a normal user after your account is 2 weeks old.
Welcome. To the community.


#3

Still doesn’t work for me. I uncheck the box, add the tracklist but when I go to save the edit, the tracklist appears as if they were all new recordings, even tho I associated the tracks with the already existing recordings, and then if I save it, the same message appears on the release with no tracklist at all.


#4

There’s a known bug that (sometimes?) if you assign already existing Recordings to the track list of a new Release, the system will fail to submit the Release properly. The best way to work around it is to simply create new Recordings and then merge them afterwards. @jesus2099’s “mb. MASS MERGE RECORDINGS” userscript (available on Greasy Fork and on Open User JS and on GitHub) can help a lot towards making this a much less cumbersome endeavour. (See Guides/Userscripts for more information about userscripts.)


#5

I hopefully never had this bug. Do you think only limited users can have it?
Or maybe it’s just that the server is overloaded when the release editor tried to add its AJAX edits (add medium).


#6

I’ve had the bug happen to me, so it is not only limited users. I don’t know if there’s any correlation with server stress, but I have been able to reproduce it consistently before, so I doubt that that is related.