Cannot save library

musicbrainz
picard
Tags: #<Tag:0x00007fcb57432360> #<Tag:0x00007fcb57432220>

#1

My iTunes library won’t read my windows ITL file and my whole 7500 songs are completely messed up. So, I have gone through all the necessary steps to try and regain my library. I opened my music file, then I clustered the files, ran the look up and scan. Then after lots of rescanning and some grunt work I got 95% of my library found and added to the right side. I’ve been trying to now get it to save, I select all of my files, all 7491 of them; but when I click save, the program becomes unresponsive for hours and when it comes back online, nothing has been saved. I’ve tried to only do a few albums at a time, but still nothing saves. Please help! I also see no check marks, only images of cd’s, green music notes, and red circles with minus’s in them.


#2

Firstly:

  • Only do an album or two at once at first. Later on you can increase it, but Picard will have issues if you do thousands of files at once.
  • Backup your music just in case - Picard can and will overwrite tags and filenames permanently by default.

The red stop symbol means there is an error writing to your file. The first thing to do is make sure that your files aren’t set to read-only (that’s usually it when I have that happen).

Sounds like your workflow is good (cluster > lookup > scan (if necessary)), but your examples pictures don’t show many complete albums. Unless you don’t have many full albums on your drive, or don’t care about album info, I’d look into trying to get more complete matches (eg finding the right album for one track, and then manually dragging and dropping the rest of the cluster onto that album).
Hope that helps!


#3

I’ve even tried only doing one album at a time and it still won’t save.


#4

I’ve just done a first pass of 8900 files myself.

I’d echo the advice of not doing too many at a time as I got froze out at the point of saving if I tried to creep the wrong side of 450 songs at a time and I’d definitely suggest trying to move songs around to get the gold discs, then remove the empty folders from the right side (I’m working on the assumption that this frees up some more memory, though it also looks tidy ) and then try saving again.

As I got down to the last few hundred, I kept getting frozen out at much smaller numbers.

I worked out that I each time I got frozen out I had been dragging the same few albums in. I avoided these albums and then as I got to the last 100 songs went 1 album at a time. It was 1 particular album that Picard didn’t like, my media players didn’t like that album so much either so I wagered it was somehow corrupted. I deleted the MP3s just for that album and re-ripped it. Then it seemed OK.


#5

As aerozol wrote that red stop sign indicates an error. This is unrelated to the number of files you save (that part is more about Picard becoming unresponsive for a long time). Often this is caused by the files being read-only / write protected. So make sure this isn’t the case.

Please look at the output of Help > Show Error/Debug log and post it here and we can hopefully figure out what the cause is.