Cannot Drag & Drop Files and/or Folders Any More?

Tags: #<Tag:0x00007f41a3e04bb0> #<Tag:0x00007f41a3e04ac0> #<Tag:0x00007f41a3e04958> #<Tag:0x00007f41a3e047f0> #<Tag:0x00007f41a3e046b0>

Has the ability to drag & drop files and/or folders into Picard 1.4 been removed?
I just downloaded and installed the new release today, and was quite surprised when the files I wanted to lookup, would not stay in the left-hand window, neither in unmatched or clusters. The use of the buttons to add files or folders, waiting for the window to pop up, and then choosing the files or folders, is a bit antiquated, eh?
Dragging and dropping worked best for me, I’ve been using that method for years, and I would hate to think that it is no longer available.
Will someone tell me if I am doing something wrong, or if there is something I need to configure to get that functionality again?

Thank you in advance.

Is it possible you were running Picard in Windows as Administrator? You cannot drag and drop between applications running as normal user and applications running with elevated administrator rights.

Same problem, using OS X 10.12. It worked in the beta 1.4 I was using previously.


Feb 14 23:07:34 Al[1] ( Picard[33761]): Service exited due to
signal: Killed: 9 sent by CoreServicesUIAgent[32552]

Feb 14 23:21:29 Al MusicBrainz Picard[34254]: assertion failed: 16D32: libxpc.dylib + 74307 [65E41BB6-EBD5-3D93-B0BE-B190CEE4DD93]: 0x89

Feb 14 23:21:33 Al MusicBrainz Picard[34254]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked

Drag and drop of both files and folders works exactly like I’d expect here on Windows 7 with the final Picard 1.4.

What operating system do you use @AntBee?

Seeing this too in MacOS 10.12.3. You can’t drag to the MusicBrainz window. You can drag to the icon in the Dock and they are added as you would expect.

@AntBee Are you using OSX, too?

Sorry for my delay in responding, but yes, I am using OSX 10.11.6


Huh, totally forgot you could do that.

The only workaround that I have found, that does allow one to drag & drop, is to have a third column, the File Browser, open. Find where the files are that you want to work with, and that column allows one to drag & drop.
I find it tedious, plus it has taken me out of my “comfort zone,” whenever I used Picard prior to this update. But, you will not find me screaming for a “fix,” it’s not that serious. :slight_smile:
But anyway, that is my workaround using Mac OSX 10.11.6, so I hope it works/has worked for others using a Mac.

Please report it on the bugtracker. That way it can be fixed for 1.4.1.


Fixed in

Find the fixed dev build @


Thank you for letting us know about the fix, I’ll try it out and see!


Works fine now. Thanks for the quick fix!

Music file drag-and-drop works again in the dev build linked above, thank you!

But cover art drag-and-drop still doesn’t work, whereas I remember it working on an older version of Picard. Is there any way to change a cover art, other than drag-and-drop?

fixed in

You can find the fixed build @

MacOS 10.12.3 here too. No Drag and Drop since Picard 1.4 update.

Did you try the fixed build posted above?

1 Like

Yes I did and it corrected the macOS 10.12.3 Drag N Drop issue. Thanks!