AcoustID not showing up on releases I add

See this: Recording “All Is Soft Inside (From NRK HAIK for Aurora, 2019)” by Ane Brun - Fingerprints - MusicBrainz

I added that release, and using Picard I generated the AcoustIDs, matched them to the release I added and submitted the ID’s. I also made sure to add AcoustID’s API key to Picard settings.

Still, they don’t show up there. This is happening to all of my releases. Since I can identify the files using AcoustID later on, I wonder if I should worry about this. Thanks.


Maybe it’s because there exists a standalone recording with a fingerprint already added:

This is probably the same recording as the one you want to add a fingerprint to. It is possible if you select “Generate Acoustic Fingerprints”, but it would be much better to merge the recordings. Either it was released OR it was a standalone recording.¹

EDIT: ¹) It was clearly released, available on Tidal!


It seems I have same issue with some new releases I added.
ex: Release “สิบหกปี แห่งความหลัง” by สุรพล สมบัติเจริญ - MusicBrainz

I tried sent multiple times but still no fingerprints linked to it.

And compare to upper case it doesnt seem to have another recording already linked with that AcoustIDs.
The sending function seems to work as by testing on a recording already linked to an AcoustIDs I can see the number of Sources increasing.

Is it a computation problem on server side like last time or something else?


EDIT 2022-06-28: Continuing on Picard can't match AcousticID of a track, but the AcousticID is added - #4 by ulugabi